5

Is it possible to completely remove apps from the various privacy categories in System Preferences?

System Preferences > Security & Privacy > Privacy

enter image description here

  • Do you mean specifically for calendars? – Cody Rutscher Oct 12 '18 at 14:46
  • Calendars, Contacts, Photos... Generally speaking, how do we remove them entirely? – user305944 Oct 12 '18 at 18:58
  • 1
    Unchecking them should do the trick no? – Cody Rutscher Oct 13 '18 at 5:32
5

To remove all apps from a particular Privacy category, open Terminal.app and type the following command, then type the Return key:

tccutil reset CATEGORY

where CATEGORY is one of:

  • Accessibility
  • AddressBook
  • AppleEvents
  • Calendar
  • Camera
  • Microphone
  • Photos
  • Reminders

If you want to remove only a particular app, you need to first determine its Bundle ID. Once you know that, issue the command:

tccutil reset CATEGORY BUNDLEID

Note: Specifying an app's Bundle ID appears to require macOS Mojave (10.14) or later.

You could also remove all apps from all categories:

tccutil reset All

In the example given in the question, the following commands would remove Terminal and Chrome from Calendars.

First, determine their Bundle IDs:

osascript -e 'id of app "Terminal"'

shows com.apple.Terminal. Same for "Chrome" gives: com.google.Chrome. Now we can reset them:

tccutil reset Calendars com.apple.Terminal
tccutil reset Calendars com.google.Chrome

Pro tip:

This is a one-liner doing the same:

tccutil reset Calendars `osascript -e 'id of app "Chrome"'`

More info in this blog article: Managing Mojave’s privacy protection: Privacy controls.

|improve this answer|||||
  • 2
    This answer should be marked as accepted. – janzoner Aug 15 '19 at 9:58
  • On Catalina, tccutil reset All resulted in terminal not accepting input, my keyboard not working anymore and my mouse unable to click. I had to hard-reboot with the power key. – mrm Dec 30 '19 at 21:09
1

Unchecking the checkbox prevents the application from using those services.

You cannot remove the listings directly from this window as they have requested these permissions in the past. For non-system apps like Chrome, you can remove the application from your machine and it will remove the listing from the privacy pane.

|improve this answer|||||
0

I tried clicking on the application you want to remove, but not the checkbox and then clicking the remove button (-). It worked for me, but I'm not sure if it will work for others as of yet.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .