I am using an iPhone 6s with iOS 12.4 and a MacBook Pro mid2015 with macOS 10.14.6. Since recently (I am not exactly sure when it started), I cannot charge the phone with my computer anymore. As soon as I plug the phone in, it will play the charging sound repeatedly. The right-hand side port sometimes works, the lefthand side port never works. When I connect my old iPhone 5 (using the same cable), it charges without any issues. My iPad mini 4 shows the same issue.

Sometimes the "Do you trust this computer" setting flashes on the phone and disappears before I can click anything.

How can I fix this?

Update 1

Sometimes I get the Software Update dialogue in macOS. After approx. 2 minutes it shows the following:

enter image description here

Update 2

For some reason the issue disappeared for a while but is back now. Disabling "Settings" > "Touch ID & Passcode" > "USB Accessoires" seems like it makes the problem a bit less bad, but not go away.

Update 3

This is driving me crazy. I upgraded to Mojave 10.14.3 mostly to get rid of the issue. It persists. Some more random information: Before logging in (Filevault pre-boot authentication), the phone will charge fine. Only when a user account is loaded, the issue appears. The likelihood of a successful connection increases with the battery state of the iPhone. Workaround 2 in my answer below suggest that this a "Trust issue" from the iPhone's side. I suppose the solution will have to be hidden somewhere there...

What I tried so far (will update):

  • There might be a problem with the port. Does it charge fine with a charger connected to the wall outlet?
    – airsquared
    Oct 12, 2018 at 0:31
  • @abc Thanks. No, it charges fine with whatever i use and all other peripherals work.
    – n1000
    Oct 12, 2018 at 7:36
  • Have you tried an SMC reset on your Mac?
    – Jake3231
    Oct 26, 2018 at 17:00
  • @Jake3231Thanks for the suggestion - just did - no success
    – n1000
    Oct 29, 2018 at 7:39
  • 1
    @dwightk My guess is it has something to do with the phone's authentication to macOS and vice versa. Clue #1 killing usbd service on MacOS works. Clue #2: Pressing Trust in iOS works. Clue #3: some people report success after resetting privacy feature in the iOS device. Talking about which – maybe this is what I should try once again after the upgrade.
    – n1000
    Mar 19, 2019 at 16:58

2 Answers 2


Workaround 1

This is the only reliable workaround for my iPhone.

I came across a similar question. The most up-voted answer lets me charge my phone. However, I consider it rather a workaround than a solution.

Launch "Activity Monitor" > select the usbd process > click the cross icon in the top left corner > select "Force Quit". Sometimes the process has to be repeated once.

Unfortunately, this workaround does not work for my iPad mini 4, which will say Not Charging after quitting usbd.

Workaround 2

This is a weird one... I noticed that sometimes the Trust this Computer? dialogue appeared for a split second. However, it did not appear long enough to actually click the Trust button (left button). After playing whack-a-mole for a while, I accidentally opened the Calculator App. There I was able to catch the dialogue and then I was asked to enter my Passcode. After repeating this twice it worked even after rebooting the computer. The phone will work randomly for a while.


I have also experienced this but a simple unplug and plugging back worked for me. I suggest:

  1. Opening iTunes and try to see a possible reason in the sync settings. I think toggling auto sync on or off might help.

  2. See if personal hotspot is on or not, turning it off should be good.

  3. Deauthorizing the Mac and undoing it in the iTunes-> account menu.

From this Apple discussion thread,

  1. Airplane mode while charging.

  2. A new cable which I see you have tried.

  • Well, this is awkward. At the moment I cannot reproduce the issue. "Unfortunately" my iPhone is charging fine right now. No clue what happened... I will provide feedback as soon as I am able to reproduce.
    – n1000
    Mar 24, 2019 at 8:51
  • Was there some update of iOS or macOS?
    – anki
    Mar 24, 2019 at 14:05
  • No. It is so weird. The issue occurs more often when the battery is low. The last few days it occurred much more rarely.
    – n1000
    Mar 25, 2019 at 11:53
  • I finally tried your suggestions: 1. Nothing out of the ordinary. 2. Never made a difference. 3. Just tried – did not work. 4. No difference. 5. As you say – cable is fine.
    – n1000
    Mar 25, 2019 at 11:55
  • Try apple support maybe and please update us too :)
    – anki
    Mar 25, 2019 at 17:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .