1

After the new update to macOS (Mojave), I can't access the camera. I'm using a python script with opencv and imutils (doing some object detection), and once I run the script, it stops. After the debug part I'm seeing that it stops once it call the VideoStream from imutls.video. .

"vs = VideoStream(src=0).start()"

So, when I open the Security & Privacy > Privacy, I'm seeing that the new macOS have added Camera and Microphone options. There is no "+" or "-" sign to add additional programs in order to access. Even if there is, I'm not sure if I can add a python script.

If someone has some kind of solution about this, please feel free to share it.

1

I have found the solution here:

I found the solution! I tried running the script using the default terminal that comes with mac and it worked :) So it seems there was some weird issue with the third party terminal (iTerm) I was using

I used the macOS Terminal and it seems to be ok. So the new Security features are preventing iTerm.

  • Note that while iTerm was not mentioned in the OP and since this is a self-answerd question, we can assume iTerm was unintentionally left out of the OP and the answer is most certainly relevant since it was self-answered. – user3439894 Jan 8 at 18:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .