Prior to Mojave, I used a custom Shortcut (System Preferences>Keyboard> Shortcuts>App Shortcuts) for the 'Tags…' command (Finder, File>Tags…), as in this answer: https://apple.stackexchange.com/a/112852/63961.

After updating, this shortcut stopped working, and the keystroke no longer appeared in Finder's File menu next to 'Tags…'. The custom setting was still present in System Preferences.

I've attempted to reset this by clearing the old shortcut and re-creating it, with a variety of different keystrokes, and with alternate spelling for 'Tags…' (i.e., with three periods for the ellipsis character). Other custom shortcuts do work in Finder, for menu items either already having built-in keystrokes, or when no built-in is present. The Finder Toolbar button for the 'Tags…' command works fine, as does the menu item itself.

  • (You certainly typed 'Tags ...' with a space in front of the dots, right.) – clemsam lang Oct 10 at 22:29
  • Yep, that too. :( And with a space and three periods. Although obviously none of these should work anyway. Does a Tags… shortcut work for anyone else in Mojave? Perhaps it's a bug just for me, in which case I should delete this question. – Jeremy Needle Oct 11 at 4:28
up vote 6 down vote accepted

In Finder, go to preferences, then Tags. Remove all favorite tags, and the shortcut should work.

  • Thanks! That worked for me. (Note: I have the shortcut configured as "Tags..." where the "..." are added via 'Option+;' – mark Oct 28 at 8:19
  • Amazing! Incidentally, this also fixes the inability to access the menu item using arrow keys. Hopefully, the glitch does not recur if new Favorites are added. But I could live without them. – Jeremy Needle Oct 29 at 4:06
  • I have no idea how you discovered that, but thank you! – wjv Nov 19 at 13:14

The work around above doesn't work for me and I think there is a real bug in the OS. When you work with cursor keys manually (i.e. without using Karabiner and pressing ctrl-f2, right_arrow, right_arrow, down_arrow, t, in order) the final 't' command takes you to Rename since the OS cannot see the Tags… command. Even if you move the cursor by pressing the down_arrow key a few more times it moves to the 'Find' command at the bottom and then the next down_arrow keystroke makes the highlight disappear as if the Tags… item weren't there.

  • Hi, I looked into your helpful description and think I found a solution. Will you please tell me the name of the most downward item in File menu that reacts to manually typing its 1st letter, once the menu is dropped?!? Can you reach "Tags…" by arrow keys at all? IF SO, you could just change the script's "t" for this "previous" one and insert one (or more) "down_arrow" commands in front of "return_or_enter"... – clemsam lang Oct 11 at 23:35
  • Wow, this is a fascinating/worrying error you've pointed out, thanks. – Jeremy Needle Oct 12 at 3:42
  • 1
    When I use arrows to move past Find to Tags…, then menubar highlight simply vanishes, and then hitting enter seems to do nothing at all. – Jeremy Needle Oct 12 at 3:49
  • Well, Apple seems to really want to keep some things DIFFERENT. No wonder Karabiner (full version) takes so long to adapt/develop … I'll add a workaround-workaround to the above code that may work in SPITE of this "obstinacy" … ;-) ;-) ;-) – clemsam lang Oct 12 at 5:58
  • I am afraid any further attempts to solve your Mojave-related problem NOW will be fruitless, as I am on High Sierra and will wait some months until Mojave is a little more trustworthy. SO: I cannot really test whatever ways there may be to help you. Sorry. – clemsam lang Nov 5 at 8:36

I got it to work again!

In Finder settings, remove all the favorites in tags. Then go to a file and manually click Tags... from the menu bar, type in a tag and press enter. Next time the shortcut works, on all other files too.

EDIT:
It seems that Apple very rigorously prevents keyboard access to "Tags…" in Mojave.
As I still work with High Sierra, I cannot test any workaround for this restriction. Sorry!

Here's a workaround [NOT for Mojave +], if you don't mind using a free third party app (GitHub:) "Karabiner Elements".
(KE is a key re-mapping tool and preference panel "app". It can easily be closed temporarily or uninstalled via its "Misc" tab.)

Start by copying/pasting this code into BBEdit/TextEdit.

[EDIT:] THEN save file as "Finder-Tags.json" into: ~/.config/karabiner/assets/complex_modifications.

{"title": "Finder … ''Tags…''",
 "rules": [
          { "description": "Finder:  ''Tags…'' ",
            "manipulators": [
                { "conditions": [
                      { "bundle_identifiers": ["^com.apple.finder"],
                        "type": "frontmost_application_if" }
                                ],
                        "from": { "key_code": "t",
                                  "modifiers": {
                                      "mandatory": ["left_command"] }
                                },
                          "to": [ { "key_code": "f2",
                                    "modifiers": ["left_control"] },
                                  { "key_code": "right_arrow"},
                                  { "key_code": "right_arrow"},
                                  { "key_code": "down_arrow"},  
                                  { "key_code": "t"},  
                                  { "key_code": "return_or_enter"}
                                ],
                        "type": "basic" }
                            ]
}    ]    }


Now, what you see is some code that re-maps your "Cmd-T" to a sequence of key-press´es, starting with Cmd-F2 to access finder's menus, followed by some simulated arrow-key navigation to pull down "File" menu and finally a "t" to reach and "enter" item "Tags…"

All this funny mixture is necessary, as there are TWO menus (Finder & File) with starting letters "Fi", which prevents getting to "File" easily.
At the beginning of the code "bundle_identifiers": ["^com.apple.finder"] restricts this shortcut to your Finder, and ONLY works if it is the frontmost_application.

Fine!
If you want to try this very easy method, do it this way:
– Find, download and install "Karabiner Elements" from GitHub
– Open it and its tab "Complex Modifications " – Press [+ Add rule], scroll to "Finder: Tags…" and press [+ Enable]

Btw:
It is just as easy to create a shortcut to open the context menu and next a "Tags…" window from there. But THAT shortcut would demand your cursor to hover over a selected file.

  • Right, that's what I meant by alternate spellings. I'll edit the question to be clearer, thank you. – Jeremy Needle Oct 10 at 21:26
  • (You certainly typed 'Tags ...' with a space in front of the dots, right.) – clemsam lang Oct 10 at 22:28
  • (Just EDITed my now superfluous answer above to post an alternative or workaround for your problem, in case system reservations somehow prevent you from using an Apple's shortcut.) – clemsam lang Oct 11 at 9:39
  • Hm. I appreciate this workaround. It seems that, as nick g mentioned, the Tags… menu item can't be reached by arrow keys (or other keys); does that mean this solution won't work? – Jeremy Needle Oct 12 at 3:47
  • It means, another way to access "Tags…" in File menu must be tried … – clemsam lang Oct 12 at 6:33

Accepted answer above work for me as well. But only after a restart of the computer. The culprit is most likely not the Tags, but the Shortcuts!

The problem with above solution is that deleting "Favorite Tags in Sidebar" in Finder Preferences also removes these custom tags from the files! So - if you want to keep your files tagged - try these steps below:

1.

  • Reenter the shortcut in System Preferences.
  • Restart your Mac.

2.

  • If problem resists - Delete (or move) Finder prefs (path: ~/Library/Preferences/com.apple.finder.plist)
  • Restart your Mac.
  • Enter the shortcut in System Preferences.
  • Restart your Mac.

Finder prefs contains the “App shortcuts” (and some other settings, not that hard to recreate), not the “Favourite Tags”. To remove the Finder prefs is a common solution to basic problems. If you never tried it before it may be handy to know that you keep the old file, and if you wish, put it in place again (and immediately restart your Mac) to get your old settings back.

————————————

The menu-name of “Tags…” can be entered with three dots or with an ellipse, they both work. The shortcut can be a global shortcut or a shortcut for the Finder only. The key combination given to the shortcut of “Tags…” will not show up in the File-menu as other shortcut key combinations does.

————————————

Shortcuts in Mojave shows some buggy behaviours. Sometimes when entering four or five shortcuts at once the entered menu-names suddenly disappears. After a restart they show up properly.

The shortcut for “Tags..” seems extra troublesome. Tags seems to be hooked into Finder and also have some other dependencies. The problem is probably due to synchronisation of plist and defaults files.

If opening the window of “Finder Preferences - Tags” the shortcut of “Tags…” may stop working. Opening Finder Preferences - but not viewing the Tags section - seems to not render the shortcut nonfunctional.

Sometimes, but rarely, it is enough only opening System Preferences window to render the shortcut nonfunctional. Other entered custom shortcuts will work just fine though.

A restart always solves the problem.

————————————

A tip:

You can view your shortcuts in the default-file. Type “defaults read” (without quote-marks) in Terminal. Search for “NSUserKeyEquivalents” (without quote-marks).

The shortcuts will show in two places (if applied).

In “Apple Global Domain” section it may look like this:

NSUserKeyEquivalents =         {
      "About This Mac" = "@^a";
      "System Preferences..." = "@~,";
};

In “com.apple.finder” section it may look like this:

NSUserKeyEquivalents =         {
    "Show Search Criteria" = "@^s";
    "Tags..." = "@^t";
};

That means you could also do a “defaults-write” to set your shortcuts. (Not recommended if you do not know how to do it properly).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.