3

I've seen some topics asking for help (others offering it) re: apps asking for permission to use accesibility functions with regards to VNC in Mojave. RealVNC has a page describing the issue and a fix for their client. I use iTeleport, which works with macOS' own screen sharing. The connect app is not really maintained anymore but it's still a great option for iPhone owners.

The problem is, Mojave left it function as view-only and that renders virtually useless.

So, how do you fix this?

  • 1
    I have had zero issues with this. I can control my computer as normal from other Macs, or from Remotix on my iPhone, and I didn't get any vnc-related permissions prompts. – Wowfunhappy Oct 9 '18 at 21:37
  • I haven't had any issue either doing it from other macs. Also, as I said, some apps like RealVNC or JumpDesktop have already implemented a fix or at least a workaround. In the case of iTeleport, however, control was just not working (and not displaying a permission request dialog either, which is why I had to find out exactly what process needed to be authorized) – Gregorio Litenstein Oct 9 '18 at 22:03
6

I couldn't find an answer online so I took to checking for incoming connections and also in the list of active processes so I could find how to fix it. You need to grant Accesibility privileges to AppleVNCServer which you can find under /System/Library/CoreServices/RemoteManagement/AppleVNCServer.bundle/Contents/MacOS/AppleVNCServer

  • 2
    I can't add the path to the Accesibility Controlapane in System Preferences. Because AppleVNCServer.bundle cant activated in this filedialog. How I can add this path to Accessibility Controlpane? – kockiren Nov 8 '18 at 8:05
  • 1
    @kockiren what you do is in a regular finder window, "show package contents", on the bundle, and then navigate to the folder that contains the binary file. Then drag the file from there to the Accessibility open dialog. I had to restart to get the change to apply. – idij Nov 8 '18 at 12:55
  • This works, thx. – kockiren Nov 8 '18 at 12:59
  • 1
    Also open /System/Library/CoreServices/RemoteManagement/AppleVNCServer.bundle/Contents/MacOS/ in terminal does it nicely in one go. – BaseZen Jul 31 at 23:57
  • found the file, thank you for this. This did not solve my issues connecting with TigerVNC. Am stuck on a 1280x1024 resolution to my MacMini :( – ionescu77 Nov 30 at 15:56
1

As VNC explains, you have to grant access to the vncagent application.

Step by step reproduction:

  1. open System Preferences > Security & Privacy > Privacy > Accessibility
  2. Click the lock button
  3. Click on +
  4. Navigate to /Library/vnc/vncagent and select the Open button
  • 1
    Yes and no. That is correct for their product obviously, my issue was with apps that connect using Apple's own VNC implementation. – Gregorio Litenstein Oct 24 '18 at 18:16
  • On 10.14.5 at least, this directory no longer exists and vncagent is not found anywhere. – BaseZen Jul 31 at 23:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .