9

I recently updated my Mac to Mojave.

I have several apps (e.g. Dropbox, Backblaze, Stay) that require specific permissions that can be granted via System Preferences > Security & Privacy > Privacy.

Since the update to Mojave, I can no longer add any apps to the mentioned Preferences pane. For example, when going to the "Accessibility pane ("Allow the apps below to control your computer") and adding an app via the + button or by drag & drop from the Finder, the action is simply ignored and the list stays empty.

Any idea to work around it?

Screenshot of the empty list

7
  • Backblaze needs v5.4.0 - you should have had an email about it from them. The others, idk. – Tetsujin Oct 9 '18 at 15:18
  • did you try to disable the SIP ? – Ruskes Oct 10 '18 at 4:43
  • 1
    @Buscar웃 that seems a bit drastic to me and I'd do it only as a last resort, since it decreases security. – gavrie Oct 10 '18 at 6:57
  • 1
    Hi @Gavrie! Have you tried tccutil reset All in Terminal? I have seen some references to that as a way to "reset" these permissions, although there seems to be some discussion as to whether "All" still works or not (the man page only says that it can do things like ` tccutil reset AddressBook` and does not mention All directly. I hope you get it working! – TJ Luoma Oct 10 '18 at 15:08
  • 1
    I don't have enough reputation to answer this but since this question blocked me from months, I feel a civic duty to share my solution. I had disabled SIP to do something else a few months ago. Turns out disabling SIP not only lifts a few restrictions, it also stops many permission dialogs from popping up at all even if the permissions are actively enforced. This affects Calendar and Screen Recording a least. Enabled sip solved it immediately. Apps appeared in those lists and worked properly. Resetting TCC, deleting tcc.db, etc did not work for me. – Ryan Poolos Mar 23 '20 at 12:07
2

I ended up uninstalling Backblaze completely (even though it was the up-to-date version 5.4.0 that supports Mojave) and then reinstalled the same version from scratch.

This took care of the issue.

2

Removing /Library/Application Support/com.apple.TCC/TCC.db file and restarting the system solved the problem.

In addition you probably have to restart in recovery mode and do a csrutil disable.

Then you can reboot and delete the file. Don't forget to csrutil enable in recover mode after it's done. And reboot again to use the system.

3
  • Unfortunately, the issue reappeared after a few days. Coupled with random freezes now. I really hope Apple is gonna fix this soon.. – user307394 Dec 8 '18 at 13:05
  • This worked for me the file that needed to be removed was under the user directory, not global: ~/Library/Application\ Support/com.apple.TCC. – Graham P Heath Aug 6 '20 at 16:54
  • Worked for me. I hope the problem doesn't reappear in a few days. This was driving me insane. – Sridhar Sarnobat Jun 10 at 18:51
1

I had same problem which was in my case caused by ESET. Now after I uninstalled ESET I am able to see list of apps in System Preferences > Security & Privacy > Privacy.

But whenever I add or delete app from the list my Mac strangely freezes like I can move cursor but I am unable to click on anything until restart.

1
  • Had this same error. As @Forest suggested, uninstalling ESET did the trick. (But I didn't have the same freezing error as @Forest.) – Seth Jan 14 '19 at 22:26
1

In my case, my per-user tccd was disabled somehow.

  • Open Terminal.app, and run launchctl list | grep -I com.apple.tccd
  • If no matches are found, re-enable your user tccd using

    launchctl load -wF  /System/Library/LaunchAgents/com.apple.tccd.plist 
    

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .