I have a MacBook Pro (Retina, 15-inch, Mid 2015) running 10.13.6 and I am now getting "Bluetooth: Not Available" in the menu bar. I also cannot access the "Bluetooth" section within System Preferences.

no bluetooth

Under "Network" in System Preferences it says "Bluetooth PAN is not connected" and "No PAN devices found".

system preferences

Under System Report, it says "No Information Found" under Bluetooth.

system report

I have tried the following in an effort to troubleshoot:

  • Simple restart
  • Simple shutdown, turn back on
  • No USB devices are connected, so I have none to remove
  • Reset the SMC
  • Delete .plist files in ~/Library/Preferences/ (there were no com.apple.Bluetooth.plist file in this directory for me, I had to go into ~/Library/Preferences/ByHost to find two com.apple.Bluetooth..plist files
  • Reset NVRAM
  • I'm unable to reset the Bluetooth module as Shift+Option and clicking on the Bluetooth menu in the menu bar does give me an options.

What other options do I have to troubleshoot this? If this is a hardware issue, do you have a recommendation for a Bluetooth USB adapter that I can use to limp by with?

  • Hello John, welcome to Ask Different. What do you mean by I also cannot access the "Bluetooth" section within System Preferences.? Is it grayed out? The message you see in System Preferences>Network is normal if you don't have a Bluetooth device (for example an iPhone in Personal Hotspot mode) acting as a network interface.
    – jaume
    Commented Oct 9, 2018 at 14:28
  • Thanks @jaume, I added an image of this. Bluetooth is not available within System Preferences, when searching for it from Spotlight, I then get the error message shown.
    – John_Henry
    Commented Oct 9, 2018 at 15:06
  • Thank you for posting the screenshot, it looks like a hardware issue, the Bluetooth board may defective and need replacement. To be sure, if you open System Information (Apple menu>About This Mac>System Report...), do you see something listed under Hardware>Bluetooth?
    – jaume
    Commented Oct 9, 2018 at 15:15
  • Added another screenshot with this, but it says "No information found" in System Report....
    – John_Henry
    Commented Oct 9, 2018 at 15:38

2 Answers 2


If one reset of the SMC doesn't restore the function, you've done all the triage except for one last ditch option before hardware repair or dropping an USB BTLE adapter on.

  1. Install a clean new 10.14 Mojave installation onto an external drive and let it update the firmware and then test without any user data migration or app installations. A total clean OS install can sometimes restore the drivers or state of the adapter if it's hung up and not a hardware issue.
  2. Hardware repair is likely going to be costly so I've had very good luck with all manner of BTLE 4.0 dongles that use USB connectors. They cost $9 or so for good quality - try and look for one that says Mac compatible or buy from a company that accepts returns or can offer pre-sales assurance your chosen macOS will work. OWC is a good solid Mac centric vendor but I don't see them stocking, so this Amazon search should get you going: https://www.amazon.com/s/ref=nb_sb_ss_i_1_4?url=search-alias%3Daps&field-keywords=btle+dongle
  • Thanks @bmike, I think I'll go the route of the BTLE dongle.
    – John_Henry
    Commented Oct 9, 2018 at 18:24

In terminal, also remove the com.apple.driver.AppleBluetoothMultitouch.trackpad.plist and com.apple.driver.AppleBluetoothMultitouch.mouse.plist files from ~/Library/Preferences.

cd ~/Library/Preferences
sudo rm com.apple.driver.AppleBluetoothMultitouch.mouse.plist
sudo rm com.apple.driver.AppleBluetoothMultitouch.trackpad.plist

Then restart. That fixed it for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .