3

I've noticed an annoying behavior with Mojave (macOS 10.14). I use the Messages app all the time. Previously I would just hit the red X to close it when I was done messaging for the moment. The program however would remain open, just hidden. Now, after I hit the red X, within a few to perhaps 30 seconds, the Messages app closes completely (I can tell because the indicator dot on the Dock goes away). As a result, when I relaunch it, it takes an extra second or two (this can add up), and it sometimes opens in a different location than where it was before. Is there any way to turn off this behavior?

  • 1
    so just use minimize instead close – Ruskes Oct 8 '18 at 19:23
  • @Buscar웃 Sure but I'd rather not! Also just curious about why this behavior was changed and if it can be customized by the user. – Craig W Oct 8 '18 at 19:26
  • 1
    Can't repro. Closing the window does not close the app. – Tetsujin Oct 9 '18 at 6:26
  • 2
    It used to be the rule to keep a communication app open till you explicitly Quit. Skype still does that. The reason was to be able to still be contacted by others even if the window was closed. Why did Apple decide to change that ? who knows ! – Ruskes Oct 9 '18 at 8:11
  • 1
    See accepted answer here: apple.stackexchange.com/questions/342893/… – Redarm Nov 17 '18 at 21:53
1

This is a feature introduced in macOS Lion 10.7 in 2011. If you're only noticing this since Mojave, that's a bug or the following setting you changed previously has been reset to default.

By default, since Lion, apps which support automatic termination with no open windows and not activated will quit after an idle period.

To disable this for all apps, override NSSupportsAutomaticTermination:

defaults write -g NSSupportsAutomaticTermination -bool false

To find apps which support automatic termination in your /Applications folder, you can use

grep -nl NSSupportsAutomaticTermination /Applications/*/Contents/Info.plist

Note that automatic termination is distinct to functionality more commonly used by third-party apps: applicationShouldTerminateAfterLastWindowClosed(_:).

  • I disabled it for all apps but Messages is doing the same thing. I disabled System Integrity Protection to edit /Applications/Messages.app/Contents/Info.plist to disable it for that app only, and it worked like before until I rebooted and re-enabled System Integrity Protection, and then the Messages app would crash on startup until I restored the original Info.plist. – Craig W Oct 9 '18 at 13:07
  • 2
    The app still closes after so many seconds when using defaults write -g NSSupportsAutomaticTermination -bool false. I hope there is a solution, as it is a very annoying feature 😑 – Crimbo Oct 27 '18 at 8:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .