2

I am having an odd bug with the Preiview app.

Text is getting highlighted normally. However, on the "Highlights and Notes" sidepane, text slightly offsetted from the actual highlight is being previewed.

Below is a picture depicting the problem. bug-explanation

This problem has persisted from my my old laptop (Macbook Pro mid 2015 High Sierra) to my new laptop (Macbook pro 2018 Mojave).

  • what document app did you open with Preview, is that Adobe ? – Ruskes Oct 8 '18 at 18:00
  • What do you mean by that? I just opened the pdf with preview directly. – Haran Rajkumar Oct 9 '18 at 6:42
  • 1
    if you can give me the link to that file so I can evaluate it. – Ruskes Oct 9 '18 at 6:49
  • Here is the file in reference – Haran Rajkumar Oct 9 '18 at 12:51
  • 1
    thank you, testing it shows I have same problem, so let me evaluate why – Ruskes Oct 9 '18 at 16:36
1

That looks like a problem with Adobe PDF file.

I tried it on a radon PDF downloaded from Web and it works fine, as long the PDF file is formatted correctly.

enter image description here

UPDATE !

In evaluating your Document, it shows a problem in text formatting (missing space between words). When trying to highlight selected text the Preview will obey the format given.

The dotted line appears and shows the problem when trying to select text, it shows it as one block.

There is not fix for that AFIK, but you can try to get fresh copy of the document.

You can use this Tool to look it up when trying to select text

enter image description here

It might show you bad formatted PDF in the dotted line box.

  • I actually tried that, but it still showed the same problem. – Haran Rajkumar Oct 9 '18 at 6:41
  • try another PDF file to check if the original one has a Adobe formatting problem. – Ruskes Oct 9 '18 at 6:47
  • I have. This is a persistent problem across many files. – Haran Rajkumar Oct 9 '18 at 12:50
  • Can you share that particular PDF? I'll try it on my computer – Haran Rajkumar Oct 9 '18 at 12:52
  • I think this is relevant here: I've been experiencing the OP's problem for at least some months now, across PDF files from a wide variety of sources (that is, not just Adobe-derived files, but even files I've Saved to PDF in OSX myself, etc.). I have also had (separate?) issues with text copied from some PDFs: emerging as a solid line without spaces, or ligatures ('fi') being omitted. – Jeremy Needle Oct 29 '18 at 21:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .