1

I just upgraded to macOS Mojave a few days ago and I have noticed an issue with the fonts displayed in Safari for sites/themes that I have created on Tumblr.

It appears that Safari reverted back to the default of Times New Roman and I'm not sure why; this is only an issue in Safari. The fonts are correct when viewing the site(s) in FF and Chrome. It is also only happening on desktop; the view on my iPhone and iPad are showing the correct font.

EX: http://romanoffsbite.tumblr.com

The font I used on this site is Calibri and it was displaying correctly until I upgraded to Mojave; now, it's loading in Times New Roman and I cannot figure out why or how to fix it.

I have searched for this issue the last day or so and all I have been able to find is the solution to the fonts showing as thin and blurry in Mojave, but there hasn't been anything, that I could find, that applied to incorrect font(s) displaying.

(the solution for the thin and blurry fonts did work)

SPECIFICS

Again, any help with this would be amazing! I'm not sure where else to go from here, so I have come to all of you smart folks :)

Thank You! Nicole

  • I can't comment on why Safari does not display Calibri (same behavior on my Mac with Calibri installed) BUT if you specify more than one font-family in your CSS (at least "sans-serif" but best to specify at least a couple more...) then it won't change fon't families when the browser can't/won't display the one font you specify. – Steve Chambers Oct 8 '18 at 17:38
  • Have you seen this thread? discussions.apple.com/thread/8567339?page=2 – Simon Franzen Nov 3 '18 at 11:57
2

Easy fix:

  • Open Safari Preferences
  • Go to tab "Websites"
  • Under General on the left side click "Content Blockers"
  • Then turn OFF content blocker for the website you are browsing.

This fixed the issue for me.

0

Try to restore the fonts in Font Book -> File -> Restore Standard Fonts…

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .