My ISP offers unlimited downloads at a certain time period at night, but I don't want to wake up to shutdown my MBP 13.3 at that time. I tried to specify a certain shutdown time using the Energy Saver option.

However, I found out to my utter dismay that Transmisison needs to be explicitly closed before it for the computer to shut down.

  • I assume you are using Transmission? Check this option in the Transmission preferences: Network->System Sleep
    – gentmatt
    Dec 16, 2011 at 16:13
  • Well, I'm using Transmission! But the option says "Prevent computer from sleeping with active transfers" - I fear if i uncheck it, my MBP would goto sleep within moments of my leaving it, stalling my transfers long before the desired time. Are you sure this is a good idea ?
    – TCSGrad
    Dec 16, 2011 at 16:25
  • 1
    I'm sure this is necessary for the computer to shut down. Uncheck this option, then simply disable Computer sleep in the system settings for Energy Saver. You do not have to disable Display Sleep.
    – gentmatt
    Dec 16, 2011 at 16:39
  • @Matt - I found out I also need to uncheck "Prompt user for - Quit with active transfer" in Transmission for this to work. With that, it works like a charm!
    – TCSGrad
    Dec 23, 2011 at 16:26
  • Great to hear that. I'll add an answer then. I think we should also edit your question in order to clarify that this problem was linked to Transmission.
    – gentmatt
    Dec 23, 2011 at 17:36

1 Answer 1

  1. In Transmission go to the preferences
  2. uncheck System sleep under Network enter image description here
  3. uncheck Quit with active transfers under General enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .