1

Setup:
* MacBook Pro 2017
* Mojave
* DELL U2717D Display
* Logitech unifying receiver and mouse m705

Mouse & receiver work have worked for a year. I upgraded to Mojave 2 weeks ago, and it has been working fine for the last two weeks.

Beginning today 10/7/18, mouse no longer works when the receiver is plugged into any port on monitor. 

Mouse works when receiver is plugged into Mac with USB C adapter.

I checked USB ports on the monitor and they still work with other USB devices.

I checked with two different Logitech receivers and mice and neither worked.

I reinstalled the Logitech software and restarted.

Still doesn't work.

I'm stumped. Does anyone else have any ideas?

  • 1
    I've a Dell that sometimes forgets it has USB ports. Shut Down, power off monitor, short wait, power on monitor, boot. Sometimes needs a warm reboot after that with the monitor left on. Odd but reproducible. – Tetsujin Oct 8 '18 at 5:56
1

Shutting down the Mac, unplugging all the cables from the monitor, and unplugging monitor power for several minutes solved the problem.

I had tried unplugging the monitor briefly earlier, but that was insufficient.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .