18

After Visual Studio Code update, its icon on Dock has changed to a very tiny one which is literally inaccessible!

There is no way you can click on it or view options.

Does anyone know how to remove it from the Dock?

macOS: Mojave (10.14)

VS Code tiny icon

  • 6
    @Buscar웃 That's Microsoft's Remote Desktop app. Also, that tiny icon looks hilarious! – Andrew Oct 8 '18 at 0:01
  • 4
    LOL, THIS IS HILARIOUS – Dev Oct 8 '18 at 13:49
23

Edit As pointed by many others (@nitive's comment below) there is a much easier way to fix this and it is killall Dock. Kudos to @nitive


Original long, boring, and not so efficient answer

LOL right after posting it, I found the answer

Fist: open the Dock config (plist):

open ~/Library/Preferences/com.apple.Dock.plist

Second: Find the item in persistent-apps: VS Code

Third: Delete the item! In this case, "Item 14"

Forth: Save the file

Fifth: kill the Dock to force it to restart

Honestly, I was expecting it not to have the VS Code icon anymore but magically the icon reappeared there with the right size!

  • 3
    "Delete that row" -- item 14 itself? Or a particular entry under it? – BallpointBen Oct 8 '18 at 13:19
  • 1
    Omg I think this answer in reverse may help to create dividers for a diff question lol – JBis Oct 9 '18 at 1:46
  • 3
    Just restarting Dock (via killall Dock) was enough for me and a few other people. No need to edit plist file – Nitive Dec 5 '18 at 8:31
  • 1
    Thanks @Nitive for pointing out command to kill dock (killall Dock), I think it should be in original answer – naffiq Dec 18 '18 at 9:58
  • 1
    @naffiq yes it must be – Bakhshi Dec 18 '18 at 22:53
8

I'd recommend removing the app from the dock and then opening it again, that should restore the correct icon. There are a few ways to remove an app from the dock:

  1. If you can left click the icon you can drag it out.
  2. If you can't drag you can Ctrl+Click and choose Options > Keep in Dock.
  3. If no clicking is possible you can manually edit the dock plist file.
  • Thanks @andrew, the only way possible was the step 3 that I came across too. Very strange bug. – Bakhshi Oct 8 '18 at 4:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .