0

I am currently trying to install and boot Kali Linux on my MacBook Pro 2018 which has the new T2 chip with boot security.

I have disabled both SIP and Secure Boot on my Mac as well as installing rEFInd on my computer with the instructions of this post.

When I boot into rEFInd, I am greeted with this window:

enter image description here

The first drive that you see just brings me to a blank screen with a no entry sign, the second option allows me to boot to macOS High Sierra (I do not want to upgrade to macOS Mojave right now) and then the third option is my Kali Linux install disk.

The problem is, when I boot to Kali Linux (File name is) kali-linux-2018.3a-amd64, I end up getting this error:

enter image description here

Why is this happening and what do I need to do in order to sort this out? I do not want to update to Mojave now due to some development tools but will be updating in the next few weeks. I am also going to be installing Kali Linux onto the same USB but on another partition so I can boot it on other computers too.

Here is the layout of my disks (both macOS and USB):

/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         500.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         499.8 GB   disk0s2
   3:       Microsoft Basic Data rEFInd                  199.2 MB   disk0s3

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +499.8 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            201.2 GB   disk1s1
   2:                APFS Volume Preboot                 43.8 MB    disk1s2
   3:                APFS Volume Recovery                1.0 GB     disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *30.8 GB    disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS Kali Linux              26.4 GB    disk2s2
   3:       Microsoft Basic Data Kali Instal             3.9 GB     disk2s3

disk0s3 is where I have rEFInd installed, disk2s2 is where I would like to install Kali to and disk2s3 is where the installer is located.

Edit:

Output of sudo fdisk /dev/disk2:

Disk: /dev/disk2    geometry: 3738/255/63 [60063744 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
 1: EE 1023 254  63 - 1023 254  63 [         1 -   60063743] <Unknown ID>
 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused

The iso file was also installed using the dd command.

  • What was the text label under each of the macOS icons? You have appeared to have installed Kali for a BIOS boot. Can you post the output from sudo fdisk /dev/disk2? – David Anderson Oct 7 '18 at 15:46
  • @DavidAnderson, Added! Seems to have a boot signature which is a good start! – iProgram Oct 7 '18 at 15:49
  • How did you transfer the kali-linux-2018.3a-amd64.iso file you downloaded from Kali to the flash drive? – David Anderson Oct 7 '18 at 15:59
  • I put that in the edit! I used the dd command. – iProgram Oct 7 '18 at 16:00
1

I am not sure how you doing what you have posted. Also, I question the wisdom in doing so.

I assume you installed rEFInd on your internal drive to be used to boot Kali Linux on a flash drive. You intend to use the flash drive to boot Kali Linux on other machines. How do you know if the other machines have rEFInd? If rEFInd is installed on the other machines, how do you know if rEFInd will be configured to scan for new operating systems to boot from? How do you know if the other computers will not be password protected to prevent you from booting from your flash drive?

I download the kali-linux-2018.3a-amd64.iso file from the Kali Linux Downloads website. I followed the instructions for OS X given on Making a Kali Bootable USB Drive website. In other words, I executed the following command.

sudo dd if=kali-linux-2018.3a-amd64.iso of=/dev/disk1 bs=1m

When I run the command diskutil list disk1, I get the following.

/dev/disk1 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *15.7 GB    disk1
   1:                       0x17                         3.2 GB     disk1s1
   2:                 DOS_FAT_12 NO NAME                 720.9 KB   disk1s2

When I run the command sudo fdisk /dev/disk1, I get the following.

Disk: /dev/disk1    geometry: 1912/255/63 [30720000 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
*1: 17    0   2   1 - 1019 190  32 [        64 -    6234176] OS/2 hidden 
 2: 01 1020   0   1 - 1020  43  32 [   6234240 -       1408] DOS FAT-12  
 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused      

I can EFI boot this flash drive from the Startup Manager. When running the same version of rEFInd you are using, I get a different icon and text label than you posted. I can boot this flash drive using rEFInd.

I realize I am using a older 2011 iMac, but I find it strange that our results differ so much.

  • Which version are you using? In the other post, you said you were using 0.11.4, I can only find 0.11.3 so I assume that was a typo? If not, can you give me a link to 0.11.4? – iProgram Oct 7 '18 at 20:48
  • I downloaded from https://sourceforge.net/projects/refind/. When I downloaded Oct 5 at 5.56 AM, I received refind-bin-0.11-4.3. When I downloaded Jul 25 at 11:14 PM, I received refind-bin-0.11.3. I download just now (Oct 7 at 4:14 PM) and received refind-bin-0.11-5.3. Have not had a chance to try this one. – David Anderson Oct 7 '18 at 21:22
  • That's strange. I go on there and it still says latest is 0.11.3. And that is what the big green download button from your link gives me. – iProgram Oct 7 '18 at 21:27
  • I always assumed the downloaded folder name was the same as the version. I booted all three of the downloads from my previous comment and all three are rEFInd version 0.11.3. I removed all my old rEFInd downloads and downloaded rEFInd. This time the folder name was refind-bin-0.11.3. – David Anderson Oct 7 '18 at 22:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.