1

I'm on a 27" iMac, running 2 external monitors in my video production studio. One is a 65" Samsung wall mount screen. I have been accustomed to having YouTube videos run in full screen mode on the 65" monitor and still be able to work on my 27" iMac screen (by "Full-Screen" I mean selecting the Full Screen icon in the lower right of the YouTube video, not the green button in the upper left of the browser window—that one seems to always disable any extra monitors). I have ALWAYS had my Mission Control prefs set with "Displays have separate Spaces" turned OFF. I mention that because the most common response to this problem is to turn that ON, but I don't work with that setting selected and never have, due to it's behaviors. This has been my setting for years, and I've never had this current problem. Something has changed recently so that when I select Full Screen mode in the YouTube video, both other monitors go dark. I've been trying for the past two hours to figure this out.

This behavior persists whether I'm in Chrome or Safari.

Any help would be appreciated.

Running High Sierra, 10.13.6

Thanks.

  • Same scenario for me. Until recently, clicking full screen on Chrome embedded videos would only use the display the video was on, not the normal macOS behavior of going into full-screen mode in a new "space" (and blanking out other monitors). It now uses the macOS full-screen mode which I do not like. I believe my Safari always used the macOS full-screen mode, so I normally used Chrome to watch videos on a second display. – pix0r Oct 18 '18 at 2:49

You must log in to answer this question.

Browse other questions tagged .