Does anyone know what could be causing this? Happening at least daily now, sometimes multiple times :(

Anonymous UUID:       9BD0D242-70AD-9DEC-BCA3-D8DCCE96A963

Sat Oct  6 09:25:04 2018

*** Panic Report ***
panic(cpu 0 caller 0xffffff7f97c9c271): "UPSB(MacBookPro13,2): thunderbolt power on failed 0xffffffff\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/IOPCIFamily/IOPCIFamily-320.70.1/IOPCIBridge.cpp:1307
Backtrace (CPU 0), Frame : Return Address
0xffffff9206baba90 : 0xffffff801746c1c6 
0xffffff9206babae0 : 0xffffff8017595274 
0xffffff9206babb20 : 0xffffff8017587544 
0xffffff9206babb90 : 0xffffff801741e1e0 
0xffffff9206babbb0 : 0xffffff801746bc3c 
0xffffff9206babce0 : 0xffffff801746b9fc 
0xffffff9206babd40 : 0xffffff7f97c9c271 
0xffffff9206babdb0 : 0xffffff7f97c9cdc6 
0xffffff9206babdd0 : 0xffffff7f97c9b0bb 
0xffffff9206babe20 : 0xffffff7f97ca59ed 
0xffffff9206babe40 : 0xffffff8017a7eef5 
0xffffff9206babeb0 : 0xffffff8017a7ec9a 
0xffffff9206babed0 : 0xffffff80174a5844 
0xffffff9206babf40 : 0xffffff80174a53a5 
0xffffff9206babfa0 : 0xffffff801741d557 
      Kernel Extensions in backtrace:

BSD process name corresponding to current thread: kernel_task

Mac OS version:

Kernel version:
Darwin Kernel Version 17.7.0: Thu Jun 21 22:53:14 PDT 2018; root:xnu-4570.71.2~1/RELEASE_X86_64
Kernel UUID: 1AE5ACFD-3B6F-3D74-AD52-31F1430DBC6F
Kernel slide:     0x0000000017200000
Kernel text base: 0xffffff8017400000
__HIB  text base: 0xffffff8017300000
System model name: MacBookPro13,2 (Mac-66E35819EE2D0D05)

System uptime in nanoseconds: 741083145668
last loaded kext at 247815655818: com.apple.filesystems.msdosfs 1.10 (addr 0xffffff7f9a9e7000, size 69632)
last unloaded kext at 308555536777: com.apple.filesystems.msdosfs   1.10 (addr 0xffffff7f9a9e7000, size 61440)
loaded kexts:
com.parallels.kext.vnic 14.0.1 45154
com.parallels.kext.netbridge    14.0.1 45154
com.parallels.kext.hypervisor   14.0.1 45154
com.parallels.virtualhid    1.0.3 3
com.intel.kext.intelhaxm    6.0.5
com.parallels.virtualsound  1.0.36 36
com.apple.filesystems.smbfs 3.2.3
com.apple.driver.AudioAUUC  1.70
com.apple.driver.ApplePlatformEnabler   2.7.0d0
com.apple.driver.AGPM   110.23.37
com.apple.driver.X86PlatformShim    1.0.0
com.apple.filesystems.autofs    3.0
com.apple.driver.AppleUpstreamUserClient    3.6.5
com.apple.driver.AppleHDA   281.52
com.apple.driver.AppleHIDALSService 1
com.apple.driver.AppleGraphicsDevicePolicy  3.20.13
com.apple.AGDCPluginDisplayMetrics  3.20.13
com.apple.driver.AppleHV    1
com.apple.iokit.IOUserEthernet  1.0.1
com.apple.iokit.IOBluetoothSerialManager    6.0.7f10
com.apple.driver.pmtelemetry    1
com.apple.driver.AppleBacklight 170.12.6
com.apple.driver.AppleIntelPCHPMC   2.0.1
com.apple.Dont_Steal_Mac_OS_X   7.0.0
com.apple.driver.AppleIntelSKLGraphics  10.3.6
com.apple.driver.AppleMCCSControl   1.5.5
com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0
com.apple.driver.AppleOSXWatchdog   1
com.apple.driver.AppleEmbeddedOSSupportHost 1
com.apple.driver.AppleThunderboltIP 3.1.1
com.apple.driver.AppleIntelSKLGraphicsFramebuffer   10.3.6
com.apple.driver.eficheck   1
com.apple.filesystems.apfs  748.51.0
com.apple.filesystems.hfs.kext  407.50.6
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
com.apple.BootCache 40
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0
com.apple.AppleSystemPolicy 1.0
com.apple.driver.AppleTopCaseHIDEventDriver 133
com.apple.driver.AirPort.BrcmNIC    1241.31.1a9
com.apple.driver.AppleSmartBatteryManager   161.0.0
com.apple.driver.AppleACPIButtons   6.1
com.apple.driver.AppleRTC   2.0
com.apple.driver.AppleSMBIOS    2.1
com.apple.driver.AppleACPIEC    6.1
com.apple.driver.AppleAPIC  1.7
com.apple.nke.applicationfirewall   183
com.apple.security.TMSafetyNet  8
com.apple.security.quarantine   3
com.apple.kext.triggers 1.0
com.apple.driver.DspFuncLib 281.52
com.apple.kext.OSvKernDSPLib    526
com.apple.driver.AppleGraphicsControl   3.20.13
com.apple.iokit.IOAVBFamily 680.2
com.apple.plugin.IOgPTPPlugin   680.15
com.apple.iokit.IOEthernetAVBController 1.1.0
com.apple.driver.AppleSSE   1.0
com.apple.iokit.IOBluetoothHostControllerUARTTransport  6.0.7f10
com.apple.iokit.IOBluetoothHostControllerTransport  6.0.7f10
com.apple.driver.AppleBacklightExpert   1.1.0
com.apple.iokit.IONDRVSupport   519.20
com.apple.driver.AppleSMBusController   1.0.18d1
com.apple.AppleGPUWrangler  3.20.13
com.apple.iokit.IOSlowAdaptiveClockingFamily    1.0.0
com.apple.driver.AppleHDAController 281.52
com.apple.iokit.IOHDAFamily 281.52
com.apple.iokit.IOAudioFamily   206.5
com.apple.vecLib.kext   1.2.0
com.apple.driver.X86PlatformPlugin  1.0.0
com.apple.driver.IOPlatformPluginFamily 6.0.0d8
com.apple.driver.usb.IOUSBHostHIDDevice 1.2
com.apple.driver.AppleIntelLpssUARTv1   3.0.60
com.apple.driver.AppleIntelLpssUARTCommon   3.0.60
com.apple.driver.AppleOnboardSerial 1.0
com.apple.iokit.IOSkywalkFamily 1
com.apple.iokit.IOSerialFamily  11
com.apple.AppleGraphicsDeviceControl    3.20.13
com.apple.iokit.IOAcceleratorFamily2    378.26
com.apple.iokit.IOGraphicsFamily    519.20
com.apple.iokit.IOSurface   211.15
com.apple.driver.usb.cdc.ncm    5.0.0
com.apple.driver.usb.AppleUSBiBridge    1.0
com.apple.driver.usb.cdc    5.0.0
com.apple.driver.usb.networking 5.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice    1.2
com.apple.driver.AppleUSBHostMergeProperties    1.2
com.apple.filesystems.hfs.encodings.kext    1
com.apple.driver.AppleActuatorDriver    1404.4
com.apple.driver.AppleHIDKeyboard   205
com.apple.driver.AppleHSBluetoothDriver 133
com.apple.driver.IOBluetoothHIDDriver   6.0.7f10
com.apple.iokit.IOBluetoothFamily   6.0.7f10
com.apple.driver.AppleMultitouchDriver  1404.4
com.apple.driver.AppleInputDeviceSupport    1404.3
com.apple.driver.AppleHSSPIHIDDriver    53
com.apple.driver.AppleThunderboltDPInAdapter    5.5.5
com.apple.driver.AppleThunderboltDPAdapterFamily    5.5.5
com.apple.driver.AppleThunderboltPCIDownAdapter 2.1.3
com.apple.driver.AppleHPM   3.1.3
com.apple.driver.AppleIntelLpssI2CController    3.0.60
com.apple.driver.AppleHSSPISupport  53
com.apple.driver.AppleThunderboltNHI    4.7.2
com.apple.iokit.IOThunderboltFamily 6.7.8
com.apple.iokit.IO80211Family   1200.12.2
com.apple.driver.mDNSOffloadUserClient  1.0.1b8
com.apple.driver.corecapture    1.0.4
com.apple.driver.AppleIntelLpssSpiController    3.0.60
com.apple.driver.AppleIntelLpssDmac 3.0.60
com.apple.iokit.IONVMeFamily    2.1.0
com.apple.driver.AppleIntelLpssI2C  3.0.60
com.apple.driver.AppleIntelLpssGspi 3.0.60
com.apple.driver.usb.AppleUSBXHCIPCI    1.2
com.apple.driver.usb.AppleUSBXHCI   1.2
com.apple.driver.usb.AppleUSBHostPacketFilter   1.0
com.apple.iokit.IOUSBFamily 900.4.1
com.apple.driver.AppleEFINVRAM  2.1
com.apple.driver.AppleEFIRuntime    2.1
com.apple.iokit.IOSMBusFamily   1.1
com.apple.iokit.IOHIDFamily 2.0.0
com.apple.security.sandbox  300.0
com.apple.kext.AppleMatch   1.0.0d1
com.apple.driver.DiskImages 480.60.1
com.apple.driver.AppleFDEKeyStore   28.30
com.apple.driver.AppleEffaceableStorage 1.0
com.apple.driver.AppleKeyStore  2
com.apple.driver.AppleUSBTDM    439.70.3
com.apple.driver.AppleMobileFileIntegrity   1.0.5
com.apple.iokit.IOUSBMassStorageDriver  140.70.2
com.apple.iokit.IOSCSIBlockCommandsDevice   404.30.2
com.apple.iokit.IOSCSIArchitectureModelFamily   404.30.2
com.apple.iokit.IOStorageFamily 2.1
com.apple.driver.AppleCredentialManager 1.0
com.apple.driver.KernelRelayHost    1
com.apple.iokit.IOUSBHostFamily 1.2
com.apple.driver.usb.AppleUSBCommon 1.0
com.apple.driver.AppleBusPowerController    1.0
com.apple.driver.AppleSEPManager    1.0.1
com.apple.driver.IOSlaveProcessor   1
com.apple.iokit.IOTimeSyncFamily    680.15
com.apple.iokit.IONetworkingFamily  3.4
com.apple.iokit.IOReportFamily  31
com.apple.driver.AppleACPIPlatform  6.1
com.apple.driver.AppleSMC   3.1.9
com.apple.iokit.IOPCIFamily 2.9
com.apple.iokit.IOACPIFamily    1.4
com.apple.kec.pthread   1
com.apple.kec.Libm  1
com.apple.kec.corecrypto    1.0

Model: MacBookPro13,2, BootROM MBP132.0247.B00, 2 processors, Intel Core i5, 3.1 GHz, 16 GB, SMC 2.37f20
Graphics: Intel Iris Graphics 550, Intel Iris Graphics 550, Built-In
Memory Module: BANK 0/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C31473332443450472D30393320
Memory Module: BANK 1/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C31473332443450472D30393320
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x157), Broadcom BCM43xx 1.0 (
Bluetooth: Version 6.0.7f10, 3 services, 18 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
USB Device: USB 3.0 Bus
USB Device: iBridge
Thunderbolt Bus: MacBook Pro, Apple Inc., 33.1
Thunderbolt Bus: MacBook Pro, Apple Inc., 33.1
  • Hello Rexxo, welcome to Ask Different. Do restarts happen randomly or have you noticed a pattern (when browsing, when working with a specific app, after locking or unlocking the screen...)? Do you have something plugged in to the Thunderbolt port?
    – jaume
    Commented Oct 6, 2018 at 10:15
  • Hey Jaume - The restarts tend to be after i've walked away from the machine and the screen has locked, or after i've closed the screen and re-opened (sleep mode i guess this is?). I do have stuff plugged in to the ports when I'm using it, usually power, mouse and a usb-c to screen cable, but it does seem to happen without stuff plugged in as well e.g. when it's been in sleep mode in my bag, nothing plugged in.
    – Rexxo
    Commented Oct 6, 2018 at 20:12
  • 1
    I did a quick search and found many reports of people affected by this issue, and several of them commented this seemed to happen when putting the Mac to sleep or when closing the lid. I'd recommend that you try setting Computer sleep to Never in System Preferences>Energy Saver and do an SMC reset (support.apple.com/en-us/HT201295). For a definitive diagnose bring your Mac to an App Store, if you have the possibility, and let a Genius take a look at it, it could be a hardware issue.
    – jaume
    Commented Oct 6, 2018 at 22:42
  • 1
    Here (discussions.apple.com/thread/8149427) I found a report that an SMC reset could help. The SMC can be reset as follows (see support.apple.com/en-us/HT201295 for details): After your Mac shuts down, press Shift-Control-Option on the left side of the built-in keyboard, then press the power button at the same time. Hold these keys and the power button for 10 seconds. If you have a MacBook Pro with Touch ID, the Touch ID button is also the power button. Release all keys. Press the power button again to turn on your Mac.. Could you try it and report back?
    – jaume
    Commented Oct 6, 2018 at 22:50
  • Hi @jaume sorry for not getting back to you sooner, have only just spotted this message! I've tried the SMC reset, will see if it behaves any better over the next day or so and get back to you. Thanks for your help.
    – Rexxo
    Commented Oct 11, 2018 at 22:13

6 Answers 6


I had this issue with a new MacBook Pro 2019/20 16-inch Catalina 10.15.4 (19E287)

It would frequently crash on sleep or when the screen was locked with the same error "thunderbolt power on failed" logged, now solved! (at least for my case)

The fix was to disable the extra "Thunderbolt Bridge" service (used for direct Mac to Mac transfer over thunderbolt cable) in the Network Settings

System Preferences > Network > Thunderbolt Bridge (right-click > Make Service Inactive)

disable thunderbolt bridge

Note: the screenshot says "make active" because I already disabled it. Yours would say "make inactive"

After that, no more random crashes/shutdowns on lock screen or sleep.

  • Hope this would help, it happens time to time
    – k06a
    Commented Jun 4, 2020 at 12:39
  • 2
    Fired mine back up for the first time in ages and seems a lot more stable since making this change, so marking this as the answer! Thank you!
    – Rexxo
    Commented Jun 17, 2020 at 20:36
  • 1
    Hi @Rexxo you may need to check the box to mark it as the answer, glad it helped you too, thanks! Commented Jul 16, 2020 at 8:57
  • Does not help, Big Sur same thing
    – igor
    Commented Dec 7, 2020 at 23:04
  • I upvoted this yesterday but the crashes are still happening so it wasnt the solution for me on my mbp16. SE wont let me change my vote now unless the answer is changed, so you get to keep your points :P
    – rtpHarry
    Commented Dec 17, 2021 at 12:15

I have had the same issue. Tried Beta and that made the problem only worse. I got the fix by resetting NVRAM and SMC.

To do so, shut down your Mac, then turn it on and immediately press and hold these four keys together: Option ⌥ + Command ⌘ + P + R

Please try to reset yours to see if it resolves your issue.

  • This solved the problem for me. The problem first arose after booting windows using bootcamp. Commented Mar 23, 2021 at 7:40

I had the same problem with:

  • A MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports)
  • Running on macOS High Sierra 10.13.6

It only happens when I had an external monitor connected and after waking-up the MBP after it goes to sleep (when both displays have turned off). (I'm not sure if it's relevant, but I'm using a Dell U2520D with its USB Type-C as the display connector.)

The only thing that "fixed" it was to prevent the hard disks from sleeping.

  1. System Preferences
  2. Energy Saver
  3. Uncheck
    • Prevent computer from sleeping automatically when the display is off
    • Put hard disks to sleep whenever possible

enter image description here


So, I had the same issue on a MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports) running MacOs Mojave 10.14.2.

After trying all sorts of solutions, some of them posted also here and on the official Apple Community thread (https://discussions.apple.com/thread/8149427?page=1) that didn't help I solve the issue doing this.

I have enrolled in the macOS Beta program and installed 10.14.3 Beta (18D38a). I'm running this for 2 days now and my laptop was in standby all this time without any reboots.

I know is not the best option and maybe installing a beta will mess up with other stuff but for the moment I had no issues.

Also, installing a beta will give you the possibility to send feedback and maybe that one is more taken into consideration than any other reports you send when getting that stupid error.

  • I have the same issue, running 10.14.3 (18D109) so it doesn't seem the update fixed it.
    – toabi
    Commented Mar 1, 2019 at 6:45
  • 3
    A short update from my side: the solutionI stated earlier didin't fix the problem after all, so in the end I took my MacBook in service. It is a logic board problem. They had to change that under warranty and now after almost 2 weeks that problem never occurred. So, unfortunately, this is not a software problem and can be solved only by changing the logic board. Cheers!
    – Alex Bitzu
    Commented Mar 2, 2019 at 7:36
  • 1
    You can edit your own answer if you want to update it, no need to post a new answer as a comment.
    – nohillside
    Commented Apr 16, 2019 at 17:10

I got resolved. Had the same issue with my MacBook pro-2017, another trait of it was that one of the thunderbolt ports didn't charge from the adapter. I did this:

  1. Turn off your MacBook Pro computer.

  2. Once turn off, Press and Hold at the same time: Shift + Control + Option + Power Button, for like 10 seconds. Nothing will happen on your screen, but it does all the cool stuff on the inside. It just like resets the energy flow on the circuits on the mainboard or something like that.

  3. Release the 4 buttons at the same time.

  4. Turn on your computer, log in, and try to connect something on the Thunderbolt port. It should work now...


It's been a problem for me ever since upgrading my iMac (Retina 5K, 27-inch, 2017) to Big Sur. Now on Monterey. None of the fixes on this thread, or any other, has worked for me.

The only solution I've found that mitigates the problem is to avoid putting the Mac to sleep in the first place, by going to the Apple menu and using Lock Screen, instead of Sleep.

I already require password to wake from sleep, so it makes no difference to my wake up routine.

The massive difference however, is my Mac doesn't fall over with the Thunderbolt issue when waking from the lock screen.

I recommend you also turn off automatic sleeping in the energy saving settings (unless you want belt-and-braces for security, in case you might forget and walk away without locking the screen).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .