2

I installed Mac OS Mojave on a new partition for a clean system. As I tried to merge the APFS container of the old Mac OS with the new APFS container with mojave (following the top comment of this How can I merge primary APFS partition with other empty APFS partition?) I encountered the following problem:

enter image description here

Although my SSD has 500GB storage the accessable storage is only 200GB big. When I try to resize any of the two containers with the command diskutil apfs resizeContainer disk0s2 150g I get the following error. enter image description here

The disk utility app shows this enter image description here

Using the disk utility app from recovery mode (pressing Cmd + R at startup) yields the same result.

Im out of ideas how to fix this..

  • Did you figure this out? – Adrian Dec 13 '18 at 4:14
  • Can you erase the "free space" partition by clicking it in the chart and clicking "-" button? – PickBoy Apr 22 at 5:03
1

Just faced with the same problem. I have Yosemity, separated drive without any OS and Mojave on one SSD 250. And I cant add this free space to my Mojave. only to Yusemity. If I'm not mistaken the problem is that your OS is situated on the end of the disk. I dont know how to describe it correctly, so imagine it takes not 0-50% of SSD, but 51-100%. IMHO its bullshit, but OSx developers sometimes doing things stupid AF. Sorry for offtop, so you need to move this drive to the beginning of your SSD and then you can enlarge its space. Honestly, I haven't fount the sollution yet, and I suppose I will not even search, cuz' its friday's evening=) But I suppose you'll manage that) I hope it will help you, good luck!

  • If it is still relevant, internal tool for copying one partition to another is not working for me. It was always failing during hte process. I used Carbon Copy Cloner. It have free trial for 30 days, its just duplicate one drive on the other free drive and it seems its working perfectly. It saves just everything including personal data, browser session, passwords etc. – Bonifaccio Dec 26 '18 at 13:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .