2

I run a Mac mini as a server in a small company. With macOS Server. Also a print server with a few shared printers.

This is the error message in the CUPS log:

Unable to encrypt connection, internal error

Yesterday the macserver.local self signed certificate expired. So I renewed it. Restarted the Mac. Still the same error.

What I tried:

  • Restarting CUPS
  • Turning off Sharing Printers (in system preferences > sharing)
  • Changed trust settings of certificate in Keychain to Always
  • Removed shared printer and re-add it again
  • Everything suggested here: https://discussions.apple.com/thread/7610729 (excluding reinstalling macOS)

Still the same error. What is the solution for this problem? If there is additional information required please let me know.

Cups error log:

E [11/Oct/2018:19:57:26 +0200] [Client 16] Unable to encrypt connection: Internal error

cupsd (security) in console:

CSSM Exception: -2147409622 CSSMERR_TP_NOT_TRUSTED
  • Unlikely, but an idea - is the date & time set correctly on both server and client? – Ashley Oct 12 '18 at 21:42
  • @Ashley yes date and time is correct – LH16 Oct 14 '18 at 19:32
1

I believe this thread could be of benefit to you. https://discussions.apple.com/thread/7610729

This sounds like an access/trust issue to the certificate. You can try changing the trust setting on the certificate within Keychain>Doubble Click on certificate>Trust>Always Trust

If not, the CUPS logs could be beneficial to narrow down the issue

  • I updated my question, I already tried every thing in the thread you provided (except reinstalling). – LH16 Oct 11 '18 at 18:01
  • @pjc90 Within your Keychain Acess, do you have any old keychains - on the left under 'Keychains' - that are not in use? If so, try delete those. – japes Oct 11 '18 at 22:19
  • @pjc90 Furthermore, do any of your certificates have a blue dot on the bottom right with a white '+' inside? This could mean that you have a duplicate copy of this certificate within one of your other keychains that is overriding the trust settings. Any certificate that has that specific dot, can you try setting that to "Use System Default" – japes Oct 11 '18 at 22:31
  • I deleted all old keychain items. No blue dot on the bottom right – LH16 Oct 14 '18 at 19:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .