1

This was answered in 2015, but it's not working for me:

How do I stop my Mac from ringing when I get a phone call on my iPhone?

Following the instructions there and elsewhere, I've turned off "Calls from my iPhone" in Facetime, and "Calls on Other Devices" in Settings > Phone on my iPhone, but every time my phone rings, I also get a deafening ring on my Mac.

5
  • so which app is ringing ?
    – Ruskes
    Oct 5, 2018 at 16:20
  • It shows up as a notification from FaceTime.
    – Barry Parr
    Oct 5, 2018 at 18:37
  • I've just updated to Mojave, and I'm having this issue too.
    – 2540625
    Nov 16, 2018 at 16:43
  • Not a solution but until I can come up with one, I've disconnected FaceTime from my Apple ID.
    – Barry Parr
    Nov 19, 2018 at 19:45
  • I've set my iPhone not to ring for numbers not in my contacts but they still ring through to my mac book. Anyway to stop that? Aug 6, 2020 at 1:21

1 Answer 1

2

Open FaceTime.

Go to the Preferences menu

Disable the phone numbers that you don't want to ring through to your Mac.

Turn off "Calls from iPhone"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .