0

For years, I've relied on an AppleScript (.scpt) file placed in ~/Library/Application Scripts/com.apple.AddressBook to provide click-to-dial functionality via our Asterisk PBX directly from macOS Contacts.app. Up until 10.13.6, this worked well.

Since Mojave 10.14 (also tested on 10.14.1 beta) the script's menu item no longer appear.

I've tried to inspect the running process in Activity Monitor's "Open Files & Ports" tab, thinking that maybe Apple moved the Plug-Ins folder—but that revealed nothing.

Does anyone know if this feature has been removed? Or any way restore this functionality?

I found this thread on Apple's forum (no answer yet): https://discussions.apple.com/thread/8552822

  • Not running macOS Mojave however, just a suggestion... As a result of changes made over the last several version of macOS I've switched to using FastScripts to run many of my scripts I used to create Automator Services and assign hotkeys in System Preferences for. Maybe you can mod the script to accommodate being triggered using FastScripts. Note: I am not affiliated with Red Sweater Software, the developer of FastScript, just a satisfied user for my particular needs. – user3439894 Oct 5 '18 at 15:32
  • Can you put your script into an automator service instead? I've never used application scripts, but I know for sure Automator services still work under Mojave. – Wowfunhappy Oct 5 '18 at 15:40
  • With the new privacy rules under Mojave your Asterisk PBS no longer has permission to access your Contacts. – Ruskes Oct 5 '18 at 16:50
  • @Buscar웃 That's incorrect. The Asterisk PBX never had any access to my contacts. This was an Applescript plugin that passed the contact# to the PBX using standard HTTP calls. – luckman212 Oct 5 '18 at 16:53
  • 1
    For what it's worth, I'm a developer of some Address Book (Contacts) plugins and none of them work with Mojave. I wrote Apple's developer support last week but haven't heard back from them. Just guessing that they're unsupported due to the increased privacy controls. I didn't find any updated documentation about the issue, no release notes, and the 10.14 SDKs still contain the necessary headers and frameworks to support them so I'm not sure if it's a permanent or temporary problem. – Brian Toth Oct 5 '18 at 18:17
3

I heard back from a Developer Technical Support Engineer at Apple and he said:

"I’ve asked the engineering team about this and indeed, we have removed support for both compiled and AppleScript-based AddressBook plugins in Mojave 10.14."

His suggestion was to file an enhancement request via their Bug Reporter. Sorry for the bad news.

  • Ugh. That is horrible news. "If it ain't broke, let's remove it!" is NOT how that saying goes. – luckman212 Oct 9 '18 at 18:46
  • I filed a bug: #5084145. Hope others do the same so maybe Apple will consider bringing back this useful feature in 10.14.2. – luckman212 Oct 19 '18 at 0:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .