1

I have a Mac mini with High Sierra (10.13.4) with a Windows-keyboard (it has a numpad).

Everything went fine for a long time but a few months ago I got a big problem: In many apps (Calculator, Excel, etc.) when I want to write for example "567" with the numpad, the number I push overwrites the last number. So if I push 5, 6 and 7, than instead of "567" it just shows a 7 (because the 6 overwrites the 5, and the 7 overwrites the 6).

In some apps however it works fine, for example in TextEdit or Firefox...

I probably just pushed some keyboard-shortcut which made this issue, but it really makes me go crazy. Could you please help me?

Thank you very much!

  • 2
    The first test would be try another keyboard. Though Windows keyboards have an Insert key I'm pretty sure Macs don't know how to respond to it. – Tetsujin Oct 5 '18 at 14:16
  • 1
    I tried now an old keyboard (with numpad) and with that it works fine... I don't understand this, because on my normal keyboard in some apps it does work fine, so the keyboard itself can't be a problem – Imre Oct 5 '18 at 14:36
  • BTW, thats my normal keyboard (with the problem): "HP SK-2028" i.ebayimg.com/images/i/253037003291-0-1/s-l1000.jpg (but mine has hungarian letters) – Imre Oct 5 '18 at 14:37
1

I was having the same problem with my HP SK-2028, and I found something that at least sort of works. If you turn on 'slow keys' in the accessibility settings and play with the settings a little bit, eventually there is a sweet spot where you will be able to type your numbers in, albeit a little slower, but at least it will function like it is supposed to. I found a spot in between the first two bars so I don't have to type tooooo much slower than I usually would. You can press alt+command+F5 to bring up the quick-accessibility options pane to quickly deselect or re-select slow keys as needed

-Amy

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .