5

After upgrading to macOS Mojave (10.14) I face this issue: System Preferences / iCloud reports "Update Apple ID Settings: Some account services will not be available until you sign in again". When I press "Continue", confirm again with "Continue", and supply my Apple ID password, there is some kind of processing going on for a few seconds, but then the system returns to the same point and state.

So in effect I am locked out of iCloud (e.g. cannot see calendar entries previously created there) and have supplied my password in vain.

Is this a known issue and how can it be overcome? I remember that the macOS upgrade process got permanently stuck (> 1 hour; also very annoying!) very late on (after the first login prompt and presumably also were it tried to set up iCloud) and I had to reboot the machine. Things seemed normal thereafter, but now this issue is showing up, and it may well be related.

UPDATE I've meanwhile reinstalled macOS Mojave (with Command + R) but the situation is unchanged.

UPDATE I'm by now pretty certain that the root cause must be a corrupted state that is kept by iCloud locally as persistent data that resides local to a macOS user account. Where does iCloud store such information, i.e. removing what files resets the iCloud client in macOS to a "clean" state?

  • 1
    Why was this question "protected"? It would surely be interesting to learn how many others suffer from a similar experience. – Drux Oct 15 '18 at 20:40
  • someone can, they just need to have enough reputation to provide a real answer. – dalanmiller Oct 16 '18 at 8:41
  • I would make a new user account on your computer and try logging in from there. See what happens. – Ezekiel Elin Oct 19 '18 at 3:05
  • are you able to login on iCloud.com ? – scipsycho Oct 19 '18 at 19:32
  • 1
    !!! aha !!! I solved it! apple.stackexchange.com/questions/338806/… from Terminal: defaults delete com.apple.iTunes MacBuddyStoreID – Keith Knauber Nov 1 '18 at 16:48
2

You're absolutely right, this is a very common occurrence right now. It is a known issue, to put it mildly. Its not entirely tied to Mojave per se, nor do I think your theory of "the root cause must be a corrupted state that is kept by iCloud locally as persistent data that resides local to a macOS user account", is it exactly (though it is not outside the realm of possibility). But far more likely is that you're experiencing the fallout of several recent significant changes affecting iCloud authentication across the board, due to several serious security vulnerabilities discovered in the past few months. What's happening is that Apple's tring to implement a "middle ground" approach in not simply breaking iCloud syncing across the board all at once for everyone, so some processes will continue to accept the unpatched authentication tokens, while others require immediate reauthentication. Its a mess. But: its not quite as terrible as it seems (in my experience).

Having just conquered this very thing (again) on one of my my own machine's a couple of hours ago (and having done so several times in the last couple of months), I can tell you there's unfortunately not a straightforward "1. 2. 3." solution I can give you, but your best bet is to stick with working with the iCloud Preference Pane and related rather than doing a "deep dive" just yet.

Here's what I'd recommend:

First: make sure you have an up local backup (Time Machine or the like).

Then, what you'll want to do is basically attempt to fully sign out of all the places where you authenticate with your Apple ID: App Store, iTunes, Photos, etc., and then the iCloud prefpane. Try unchecking as many synced item's as possible first, particularly Find My Mac and Keychain. These may take a minute or two to actually disengage and "uncheck", but if it takes longer than that, just force quit System Preferences and try again. Also, try clicking the "Account Details" and "Manage" buttons, the same thing will likely happen, it'll freeze up for a bit, and then it will either actually bring those panes up, or hang. Again, just keep going back, and try to get to the point where you're fully signed out, or, if you get the "Update Apple ID Settings: Some account services" box again and it doesn't hang, you'll be prompted several times, alternating between asking for your iCloud password and your local admin password. This is a good thing, it means its finally updating the local Keychain stores across the board.

Eventually (in my experience, after about 20 minutes of this, maybe 10 force quits), you should either be fully logged out of iCloud, or the "Update Apple ID Settings" thing will finally work. Once you're at that point, you should be able to re-sign in, and these issues should go away.

I know that's, um, not the most precise solution, but it has worked for me on several machines. Let me know if it doesn't work for you. But trust me, its a lot less messier than fully ripping out the iCloud keychain and authentication tokens; (at that point, you may as well just sign up for a new Apple ID).

1

I'm assuming the other answer I provided you didn't work given your "I expect a concrete answer that allows resolving the actual issue" regarding the bounty grace period, here are some "concrete" things you could do that would resolve your inability to log in. However, I must warn you they will likely lead to some data loss in iCloud and a lot of other headaches.

The simplest:

  1. Do a clean reinstall of Mojave and create a clean user account. That is:

    A. ⌘-R again, but before installing open Disk Utility (from the menu bar) and and delete all your existing partitions; reformat your drive with a single clean APFS partition, then re-install.

    B. After install, when creating your user account, authenticate using your Apple ID, but do not migrate any data from Time Machine perform and other automated restore any other type of backup. You will no longer have this problem. But you will need to reinstall all your applications by hand, etc.

  2. To answer your question regarding "removing what files resets [sic] the iCloud client in macOS to a "clean" state": What you're talking about are not kept in invididual files, but in your Keychain store. So, you could open Keychain Access.app and delete all the items that begin with com.apple.account, com.apple.cloudd, com.apple.gs.iCloud, com.apple.gs.idms, etc., as well as iMessage Encryption Key, iMessage Signing Key, etc. I can't give you a full list because which ones you will have is highly variable (it depends on which sync services you've been using). However, I cannot stress how much do not recommend you do this.

  • I'm currently traveling, but will try your recipes (and thus see whether they resolve the actual issue) afterwards. Thanks meanwhile. – Drux Oct 23 '18 at 5:07
  • Nops, #2 did not work either. So unfortunately it will come down to the software version of "buy a new machine", i.e. option #1. Very disappointed in Apple!! (Also their "geniuses" at the local Apple store could not solve this issue as caused by a "simple" upgrade.) – Drux Oct 28 '18 at 6:58
  • 1
    !!! aha !!! I finally fixed this from the command line: defaults delete com.apple.iTunes MacBuddyStoreID probably got set when I migrated my account. It should be called ‘MacBigBrotherStoreID’ – Keith Knauber Nov 1 '18 at 16:36
0

So in the end I had to delete the account, create a new one, and recover Desktop, Documents, Movies, Music, and Pictures from a TimeMachine backup as well as import mailboxes also from this backup (under Library/Mail) into Apple Mail.

Shame on Apple: based on this experience I won't hasten do perform their next macOS upgrade!

0

I had a similar experience on Mojave, where setting my primary iCloud account had no effect (after successfully logging in using [System Preferences:iCloud], it would either return to the empty login or say that I’m already signed in, even though my Internet Accounts list doesn’t show anything for iCloud).

The following terminal command sorted this out:

defaults delete MobileMeAccounts

This command will remove your iCloud account associations (both your primary iCloud account from [System Preference:iCloud] and the secondary from [System Preference:Internet Accounts]. You should then be able to sign into / add an iCloud as normal.

You must log in to answer this question.

protected by Community Oct 5 '18 at 18:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .