2

I am trying to install rEFInd on my MacBook Pro 2018 laptop with the new T2 chip that adds extra boot security.

I have both used APFS and MacOS Extended (Journaled). I have also disabled secure boot and csrutil.

When I install rEFInd using sudo ./install.sh --alldrivers --ownhfs /dev/disk0s3 (where disk0s3 is my MacOS Extended (Journaled)), I then get an error when selecting the rEFInd disk in the Startup Disk, I end up getting an error saying that there was a bless error.

How would I install rEFInd on my MacBook Pro 2018 laptop?

Edit:

If it helps, I am on macOS High Sierra and will soon be updating to macOS Mojave in the next few weeks.

This is also the format of my disk:

/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         500.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         499.7 GB   disk0s2
   3:       Microsoft Basic Data BOOTMGR                 307.2 MB   disk0s3

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +499.7 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            199.5 GB   disk1s1
   2:                APFS Volume Preboot                 44.6 MB    disk1s2
   3:                APFS Volume Recovery                1.0 GB     disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4
7
  • As a kind of side question, I'm just curious to know what the reason behind wanting to use rEFInd is, versus just using the built-in Secure Boot manager
    – Jesse P.
    Oct 4, 2018 at 21:59
  • @JesseP. I want to triple boot with windows mac and Linux for my course.
    – iProgram
    Oct 4, 2018 at 22:04
  • Oh. I see. So, if it weren't for Linux being thrown in you'd just use Boot Camp, I assume.
    – Jesse P.
    Oct 4, 2018 at 22:07
  • @JesseP. Yep. Wish it was that simple!
    – iProgram
    Oct 4, 2018 at 22:10
  • Which Linux are you trying to install? Can you give the name of the ISO file? You can also install rEFInd to either a MS-DOS or a second EFI partition. Either of these should appear in the Startup Manager. I can not guarantee either will be selectable from the Startup Manger on your 2018 Mac. You would have to try to find out. If you wish I could post instructions for the installation of rEFInd, but this would require for you to first post the output from diskutil list. Oct 4, 2018 at 23:15

1 Answer 1

5

If you wish to attempt to use rEFInd from a MS-DOS partition, then follow the instructions below. I have made the following assumptions.

  • You will be reusing disk0s3.
  • System Integrity Protection is enabled.
  • You have booted to macOS. Do not boot to macOS Recovery.
  • Secure Boot is is set to "No Security".

Below are the steps.

  1. Enter the following command to change disk0s3 to a FAT formatted partition.

    sudo diskutil eraseVolume MS-DOS BOOTMGR disk0s3
    

    You could also change the partition by using the Disk Utility application. Highlight the partition then select Erase. Use BOOTMGR for the name and MS-DOS (FAT) for the format.

  2. I assume you have downloaded the current version of rEFInd (refind-bin-0.11.3) to your Downloads folder. Enter the following command to change to the root directory of the rEFInd download.

    cd ~/Downloads/refind-bin-0.11.3
    
  3. Enter the following command to install rEFInd. I omitted --alldrivers since both macOS and Kali Linux do not needed any rEFInd supplied drivers to boot on a Mac. Also, adding --alldrivers caused rEFInd to hang on my 2011 iMac.

    sudo ./refind-install --root /volumes/BOOTMGR
    

    You should get the following alert followed by some additional error messages.

    **** ALERT: SIP ENABLED! ****
    

    You can ignore this alert. At the prompt shown below, enter y.

    Do you want to attempt installation (Y/N)? 
    

    The follow error message was expected and can be ignored.

    Could not set boot device property: 0xe00002bc
    
  4. Rename the refind folder to BOOT and the refind_x64.efi file to bootx64.efi so that the Startup Manager will include it as a startup option. This can be done with the Finder application or by entering the commands given below.

    cd /Volumes/BOOTMGR/EFI
    mv refind BOOT
    mv BOOT/refind_x64.efi BOOT/bootx64.efi
    
  5. Add a label for this new startup option. Without a label the Startup Manager will show EFI Boot which may be confusing if you have other partitions with an /EFI/BOOT/bootx64.efi file.

    cd /Volumes/BOOTMGR/EFI
    bless --folder BOOT --label rEFInd
    
  6. (Optional) Goto my Mac icons website and download the mac-icons.dmg file. Use the Finder application to mount this file. Enter the command given below to copy the rEFInd icon to BOOTMGR volume.

    cp /Volumes/mac-icns/OSX10.11.6/os_refind.icns /Volumes/BOOTMGR/.VolumeIcon.icns
    

    The icon shown below will now appear in the Startup Manager above the rEFInd label.

  7. Restart the Mac and immediately hold down the option key until the Startup Manager icons appear. Next, select the icon labeled rEFInd. Finally, hold down the control key and select the circular arrow below the rEFInd label. This effectively blesses rEFInd.

Changing which drivers are used

The drivers used to access file systems by rEFInd are stored in the /Volumes/BOOTMGR/EFI/BOOT/drivers_x64 folder. You can create a new folder named drivers_x64_not_used in the /Volumes/BOOTMGR/EFI/BOOT folder. You can then move any drivers you do not wish to be used by rEFInd from the /Volumes/BOOTMGR/EFI/BOOT/drivers_x64 folder to the /Volumes/BOOTMGR/EFI/BOOT/drivers_x64_not_used folder.

If you are still getting a grey screen or a no entry sign, this link shows that you will have to copy the apfs driver in order to boot. To do so, run the following command.

cp /usr/standalone/i386/apfs.efi /Volumes/BOOTMGR/EFI/BOOT/drivers_x64.

You may still have one boot option that shows the 'no entry' sign but the other option should now boot you into macOS instead of showing you a grey screen.

10
  • I was able to install it using your method however I have a few issues. When I boot to it, it shows two boot disks both named 'Macintosh HD'. When I boot to the first one, I just get a black screen with a white no entry sign. The second device, I am just greeted with a grey screen. How would I fix this?
    – iProgram
    Oct 5, 2018 at 13:45
  • Configuring rEFInd is an entirely different question from installing rEFInd. I do not use the --alldrivers option. The rEFInd Boot Manager: The Future of rEFInd web page has a section titled Known bugs that need squashing:. The first item reports blanks screens on the newest Mac models. The posted solution refers to the removing of rEFInd's drivers. I could also post how to manual configure rEFInd to boot macOS, but I would need to know which macOS you have installed and the output from diskutil list. Oct 5, 2018 at 19:07
  • Put the information in the edit of my original post.
    – iProgram
    Oct 6, 2018 at 11:35
  • Just found out that I was booting to a grey screen because rEFInd did not have the apfs.elf driver installed. I have edited your answer to explain how to do it.
    – iProgram
    Oct 6, 2018 at 18:58
  • @iProgram: Does this fix now allow you now boot to macOS from rEFInd? Oct 6, 2018 at 19:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .