2

I'm maintaining a bunch of Macbooks (OSX High Sierra). Each time after they have been used I delete the user "workshop" and create it again (to get rid of unwanted user data).

As a part of that process I want to install a mobileconfig file to get access to the eduroam network at our university. At the moment I'm installing the file manually each time the user account is renewed. I tried to do it via command line, so far without success:

when I run

/usr/bin/profiles -I -F path/to/file

from the admin account, the network doesn't work for user "workshop"

when I run

/usr/bin/profiles -I -U workshop -F path/to/file

I get the error message: "the user name is not valid for this command"

I can run the command when I'm logged in as workshop, but this wouldn't simplify my routine. su doesn't work either on osx. I have no idea what else to try.

  • I'm one step closer. I can run the command with option -U workshop sucessfully as admin, when I'm at the same time logged in as workshop from another machine via ssh. – Patrizio Sommatinese Oct 4 '18 at 12:25

You must log in to answer this question.

Browse other questions tagged .