1

After Mojave install I get a "No WiFi hardware installed" when trying to connect the wife. Computer response is so slow it's almost useless. Same results on iMac 27" Retina Display Mid 2015 and Mac mini Late 2012. Tried NVRAM and SMC resets to no avail. iMac worked fine when I reverted back to High Sierra but backup for mini is on the WiFi network.

1

I edited the /etc/sysctl.conf file. There are three settings adjusting socket buffers to improve broadband performance. I doubled the numbers there and it fixed the networking issues. There was a constant stream of error messages saying sockets were unable to allocate buffer memory. Apparently, there is a process crashing somewhere and not releasing it’s socket buffers. I don’t know which one is doing it because it is hard to track down due to the sluggishness.

  • Can you share modified lines, please? – Florescu Cătălin Oct 16 '18 at 12:55
  • I've checked if this file is present on my laptop, but is not.. – Florescu Cătălin Oct 16 '18 at 13:29
0

Just so you know, you're not the only one with this issue.

I can't help you with fixing this issue, but I can offer advice on restoring the backup on the WiFi iMac:

I was able to manually reconfigure the wifi when booted in to recovery mode by clicking on the wifi icon on the top left. Wifi showed 'no hardware detected' when booted in Mojave, but it DID work when booted to recovery mode - So you should be able to restore the mac mini that way.

( FYI, I have the exact same problem you're seeing, also with computers I just upgraded - An iMac and a MacBook pro. This may imply that it has something to do with software or extensions we've both installed. Unlikely to be kernel extension, as safe mode is supposed to disable 3rd party extensions. Like you, I also tried Resetting NVRAM, SMC etc with no luck.

Did you have the issue where the bluetooth keyboard and mouse were no longer detected in Mojave as well on the iMac? I needed to plug in a USB keyboard.)

  • I had no problems with bluetooth.After I doubled the socket buffers in /etc/sysctl.conf file, as mentioned in my answer to this question, everything functioned normally – hembreed Oct 5 '18 at 20:02
  • Thanks, useful information. In my investigation, I discovered configd was crashing constantly; every 10 seconds, immediately on startup. Might be related, it or might have been crashing due to socket buffers settings. If I may ask, what was your original setting, and does anyone know what the default settings are for mojave? Maybe they were increased and older installs have the older setting... – Franko Oct 6 '18 at 21:49
  • Actually, this is interesting - Two newer macs I've just looked at don't have sysctl.conf files. The two machines that I upgraded (and failed), do - From 2013. They both have old installations carried across for years. Maybe the file is carrying old invalid values that are overriding new defaults. Will delete this file, and retry the installation and update. – Franko Oct 6 '18 at 22:16
  • originally they were... # START kern.ipc.maxsockbuf=512000 net.inet.tcp.sendspace=131072 net.inet.tcp.recvspace=358400 # END – hembreed Oct 8 '18 at 7:30
  • did deleting the sysctl.conf file work? – hembreed Oct 8 '18 at 7:34
-1

I can confirm that for my iMac, just using mv or del on the /etc/sysctl.conf file and rebooting my Mac fixed the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .