4

I'm running macOS Mojave on a Mac Mini. Built-in VNC server works perfectly when you connect for the first time after reboot, however if you disconnect from it for more than five minutes you can't connect again - it displays the username that was used for the last session and a spinning wheel. Connecting via ssh and killing screensharingagentd doesn't help, only a reboot does. I've verified all the power saving settings are off. There are two virtual machines with macOS High Sierra and Sierra running on this same Mac Mini and I can connect to them without any issues.

  • I'm experiencing this too (MBP 2016 with up-to-date Mojave), but have so far been unable to determine the cause of find a workaround other than reboot. What VNC client are you using? I'm using VNC Viewer on iPhone. Just wondering if we're using the same app in case it might be triggering a bad state on macOS. – smr Oct 26 '18 at 10:52
  • Also happening from Win 10 desktop with VNC Viewer 6.18.907 (r38355) x64 I doubt it is the client as previous version of macOS worked fine – bmadtiger Nov 1 '18 at 0:20
  • Hah! Just updated to macOS 10.14.1 hoping it would resolve the issue - now I can't connect via VNC Viewer at all! – bmadtiger Nov 1 '18 at 22:21
  • I too am experiencing this ever since I upgraded to Mojave. So frustrating. I am going to try TeamViewer, see if that helps. – Simon Hughes Nov 8 '18 at 12:24
  • Same problem here. The problem also started after updates. Dealing with a relatively new macbook pro. Client is realvnc viewer 6.17.1113. – Tal Dec 8 '18 at 2:29
2

With the iMac at work, we had to turn OFF the option under System Preferences - Sharing - Screen Sharing - Computer Settings to allow VNC viewers may control screen with password. Then VNC Viewer prompts for the username & password of the iMac (assuming Only these users: is selected for Allow access for). Multiple connections work fine with that setting disabled. Hope this helps.

  • I tried turning off that option, and ensured the "allow access for" list includes my user. I then get an error message when attempting to connect via VNC "To connect to Apple Remote Desktop (10.4) or Screen Sharing/Remote Management (10.5 onwards) built-in to Mac OS X, turn on the "VNC viewers may control screen with password" option – software evolved Jan 30 at 16:19
  • Sorry, @softwareevolved I no longer have access to a Mac to help any further. Hopefully someone else can follow this up for you. – bmadtiger Feb 1 at 9:46
2

My workaround for this problem is to login via ssh and kill loginwindow process:

sudo pkill loginwindow

This will allow to login via VNC then.

0

Some more detail, as I'm seeing very similar behaviour, possibly the same.

Using RealVNC client connecting to RealVNC server on Mojave, works perfectly every time. Using this method you are connecting via the cloud using RealVNC to negotiate a session.

Using RealVNC client connecting to Macs own "ScreenShare" utility, via bonjour or local IP address, does not use the RealVNC server, and works for the first few attempts, but leave it for 5 minutes without logging in, then try again and it fails exactly as described, Lockscreen with User's name and picture, but a spinning wheel beneath, with no option to login.

Reconnecting via RealVNC server is still possible whilst in this state.

Stopping and starting ScreenSharing only kills the window with the spinning wheel, it has no other effect.

A reboot of the MAC, and it works again....for a while.

Worked fine on High Sierra.

  • 1
    Hi, Paul, and welcome to Apple StackExchange! Since this post actually describes the problem further, but doesn't answer it, this isn't really an Answer. Instead, feel free to add it to the question by pressing the improve this question link just beneath it. – Ben Leggiero Nov 5 '18 at 21:30
0

Not a fix, but another work-around to clear the locked spinny screen is to access the mac (physically) and log out the user. My Mini is in a server closet, close to my desk, so this is annoying but not too difficult.

(I am going to try the option above to tinker with the connection/login)

-1

From this article:

Apple have added a new security layer to macOS 10.14 Mojave. After upgrading your Mac to Mojave, VNC Server will allow only view-only remote access until such time as you've granted access to the vncagent application (installed as part of VNC Server).

To do this, open System Preferences > Security & Privacy > Privacy > Accessibility. Click the lock button to make changes, and + to add a new app to the list allowed to control your computer. Navigate to /Library/vnc/vncagent and select the Open button

  • Answers on Ask Different need to be more than just a link. We expect answers to be self contained, since if your link goes down, your answer will be useless. Paraphrasing the source and including any relevant information in the answer will ensure it stays relevant – nohillside Jan 31 at 11:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .