4

I have updated my MacBook Pro (15-inch, 2017) with macOS Mojave and everything is woking as per the need.

But I think new feature of macOS Mojave called Stacks is not working properly on my MacBook when I set Group Stacks By to Kind.

It just create one group with name Other and puts everything (Image, Doc, ZIP, Video) in that one group.

I tried changing Group Stacks and restarting my mac but no luck.

Is there any other setting for this which I am missing?

3

I had the same issue and found that my Finder Preferences file was corrupted. The Solution for me was to Delete the com.apple.finder.plist File and then reboot. I actually just moved the file to the desktop temporarily until I made sure that a new one was created properly....and then deleted it. Note: You will have to reset all your Finder Preferences after reboot.

Step #1: Open the “Spotlight”.

Step #2: Now enter the code directly,

~/Library/Preferences/

Next, open Preferences and then find and delete the com.apple.finder.plist File.

| improve this answer | |
  • Hi, Thanks for sharing your solution. But this is not working for me. I have removed com.apple.finder.plist two time even from Trash but still not working. – CRDave Oct 4 '18 at 5:36
3

I have same issue when I change System Preference->Spotlight setting.

From Monitor App, I found Spotlight progress takes a lot of memory, so I disable some options from Spotlight setting's *Search Results*, and then Desktop Stacks with those types disappear.

So, re-enable the expected type in Spotlight setting, the type will show on Desktop.

enter image description here

| improve this answer | |
2

I finally fixed this problem on my iMac and MacBook Pro. I was hoping Catalina would resolve it, but it did not. I then dug into some old message board threads and got a clue.

Go to System Preferences > Spotlight and uncheck Other in the Search Results tab. This immediately made the Desktop Finder stacks sort properly.

Rechecking the Other box did not cause the problem to recur, so I left it checked.

| improve this answer | |
1

I've had this problem since the Mojave beta and it just resolved itself. What I did was go into Spotlight Search Results preferences and make sure all the boxes are checked, especially the ones named for filetypes (e.g. Images, PDF Documents, etc). I had unchecked a lot of the boxes to prevent cluttering of Spotlight results since I mostly use Alfred to find files, but I think this prevented Finder from cacheing the filetype(?) which it might need to organize files into stacks. I just turned all the Spotlight boxes on and my Desktop very quickly rearranged into the correct filetype-specific stacks, so try that and see if it works. I also had to relaunch Finder (option+right click on Finder icon in the dock > Relaunch), so make sure to do that as well if needed.

Edit: This is the same as @ooops answer.

| improve this answer | |
-1

I finally got this to work:

I had to to a PRAM reset.

  1. Shutdown your mac
  2. Unplug all devices
  3. Power On and immediately hold down Command + Option + P + R for at least 10 seconds
  4. Login again and activate stacks (rightclick on desktop, use stacks)
| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .