3

I recently bought a MacBook Pro 2018, and I am experiencing an unstable connection. I mainly notice it when I am trying to play games, as spikes in latency is less notable within a browser, for instance. So the problem seems to be that the latency to my router spikes once every second or so. Here is an example of pinging my router every 200ms.

64 bytes from 192.168.0.1: icmp_seq=35 ttl=64 time=101.689 ms
64 bytes from 192.168.0.1: icmp_seq=36 ttl=64 time=2.839 ms
64 bytes from 192.168.0.1: icmp_seq=37 ttl=64 time=83.216 ms
64 bytes from 192.168.0.1: icmp_seq=38 ttl=64 time=2.965 ms
64 bytes from 192.168.0.1: icmp_seq=39 ttl=64 time=3.788 ms
64 bytes from 192.168.0.1: icmp_seq=40 ttl=64 time=137.253 ms
64 bytes from 192.168.0.1: icmp_seq=41 ttl=64 time=2.679 ms
64 bytes from 192.168.0.1: icmp_seq=42 ttl=64 time=2.925 ms
64 bytes from 192.168.0.1: icmp_seq=43 ttl=64 time=17.099 ms
64 bytes from 192.168.0.1: icmp_seq=44 ttl=64 time=3.308 ms
64 bytes from 192.168.0.1: icmp_seq=45 ttl=64 time=163.689 ms
64 bytes from 192.168.0.1: icmp_seq=46 ttl=64 time=3.797 ms
64 bytes from 192.168.0.1: icmp_seq=47 ttl=64 time=3.681 ms
64 bytes from 192.168.0.1: icmp_seq=48 ttl=64 time=3.319 ms
64 bytes from 192.168.0.1: icmp_seq=49 ttl=64 time=22.506 ms
64 bytes from 192.168.0.1: icmp_seq=50 ttl=64 time=190.864 ms
64 bytes from 192.168.0.1: icmp_seq=51 ttl=64 time=4.533 ms
64 bytes from 192.168.0.1: icmp_seq=52 ttl=64 time=3.480 ms
64 bytes from 192.168.0.1: icmp_seq=53 ttl=64 time=3.927 ms
64 bytes from 192.168.0.1: icmp_seq=54 ttl=64 time=3.422 ms
64 bytes from 192.168.0.1: icmp_seq=55 ttl=64 time=221.810 ms

As you can see, the pings are all over the place, and this behavior is consistent. On the contrary, if I perform the same test on my MacBook Pro 2011 on the same network, all pings are ~2.5ms consistently, so this Mac doesn't have this issue at all. I am using WiFi, but I am literally next to the router, so the connection is strong. And like I said, the issue doesn't appear on other devices, so I don't think the router/network is to blame. I looked at other wireless networks around, and there are not that many, so network congestion (or whatever it's called) shouldn't be the issue; also because it works on other devices. I have also performed the same test on a different network at another physical location, and the results are the same.

I have tried turning off "Wake for Wi-Fi network access" in the Energy Saver preferences, but that didn't make any difference.

I should mention that this happens even when I close all applications I have running, and I see nothing suspicious within the Activity Monitor.

Any ideas what could be causing this, or ideas as to what I should do from here to further debug the issue? Thanks!

You must log in to answer this question.

Browse other questions tagged .