I have a flash drive which was formatted on Mac using the Disk Utility. But when I'm trying to replug the drive it shows up in disk utility but says Not Mounted. I'm unable to erase as it says

Unmounting disk
Couldn't open device.
Operation failed...

It is not visible in the finder.

I also have tried formatting it from terminal using

diskutil eraseDisk free EMPTY /dev/disk2

but this stops with following error:

Started erase on disk2
Unmounting disk
Creating the partition map
Error: -69877: Couldn't open device

Also have tried this link but it also failed with error:

Started partitioning on disk2
Unmounting disk
Creating the partition map
Error: -69877: Couldn't open device
(Is a disk in use by a storage system such as AppleRAID, CoreStorage, or APFS?)

After an exhausted online search and trials I'm posting here.

Thanks in Advance

  • 1
    Restart your computer, if it doesn't work still, leave it plugged in to your computer for a half hour or so then restart. The system sees it but can't mount at the moment because the file system is destroyed probably from not ejecting properly or something else. I have had this happen. Just give it time. It should come back.
    – Jahhein
    Oct 2, 2018 at 5:25
  • Can you read or format the flash drive on another computer?
    – jaume
    Oct 2, 2018 at 6:46
  • I have tried restarting the computer but no help! and when I tried to plug it into another system (Ubuntu) it is detected but it says Read-only when I try to format it. Also tried plugging it into another mac and it behaves same as in my system.
    – BSR
    Oct 5, 2018 at 12:31
  • @BSR Did you find any solution to this? I am currently going through this problem. Jul 2, 2019 at 10:04
  • @FarrukhJaveid No, I was not able to fix it.
    – BSR
    Jul 7, 2019 at 15:55

2 Answers 2


I was able to fix this by changing the Micro SD adapter into another one and then unlocking the security switch in the sd adapter. That error occurs whenthere is a physical write protect switch on the drive, and it's locked in that position.


If this helps others, I (finally) solved this by plugging my sd-card into an adapter in the card slot. Then, since my diskutil list wouldn't even complete, and Disk Utility wouldn't even show the card, after waiting a long time (e.g. 5-10 mins), it did eventually show up in Disk Utility.

I ended up succeeding by (when it finally showed up) "repair filesystem" on the only partition it had, and then, and only then would Disk Utility allow me to unmount that partition, leading me to finally erase the drive. diskutil list finally showed the drive and my dd command started working again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .