8

Some days after installing Mac OS Mojave my quick look startet showing the spinning icon in the finder sidebar and when i press space on media files (.jpg, .png, .gif, .psd, .pdf, etc.).

Preview

Here what i tried so far:

  • Rebooted in safe mode (no effect)
  • Deleted com.apple.finder.plist and relaunched finder
  • The approach suggested here Quicklook not working

When trying the last approach my termnial freezes when i try to force reload the list using qlmanage -r.

Freeze

I then tried to generate a preview of an image, and got this error Error

I'm thinking maybe one of these apps could be causing trouble, but they didn't do in High Sierra:

  • Dropbox
  • Adobe Creative Cloud
  • iCloud drive (synced with desktop)

Any help would be greatly appreciated, for now i'm using Adobe Bridge to search files.

  • Damn, I'm with the same issue and I don't use Dropbox, neither Adobe Creative but I use iCloud Drive (but without synced Desktop). – Ricardo Pereira Oct 1 '18 at 14:51
10

A combination of the answers in here + killing all QuickLook-related processes fixed it for me. I have been experiencing this ever since the Mojave update. No reboot required.

qlmanage -r commands always got stuck for me, too.

Fix TL;DR version:

  1. Delete DropboxQL.qlgenerator from ~/Library/QuickLook (Credit to suntrop)
  2. Restart Finder
  3. sudo update_dyld_shared_cache -force (Credit to Dishoperator)
  4. Kill all QuickLook-related processes
  5. Restart Finder

Fix detailed how-to version follows

For those not very familiar with what the above means.

To get QuickLook working when previewing files with spacebar:

  1. Delete DropboxQL.qlgenerator in ~/Library/QuickLook, as per suntrop's suggestion.

    • Open Finder
    • Press ⌘+G
    • ~/Library/QuickLook
    • Look for a file named DropboxQL.qlgenerator, it will probably be the only one
    • Delete it, and then delete it from Trash
  2. Restart Finder:

    • Press ⌘ ⌥ ␛ (Command + Option + Escape)
    • Find Finder
    • Click Relaunch

To get thumbnails to work:

  1. Run the Terminal command Dishoperator suggested: sudo update_dyld_shared_cache -force

    • It doesn't do any harm, it just updates the kernel caches
    • Open Terminal
    • Paste sudo update_dyld_shared_cache -force
    • Type in your password (it will not appear as you're typing)
    • Press Return
    • It will take ~30s to a couple minutes depending on your machine
  2. Open up Activity Monitor (⌘+Spacebar, type in Activity Monitor)

  3. Order by Process Name

  4. Force quit quicklookd

    • Click on quicklookd
    • Press the X stop-like button in the top left
    • Press Force quit
  5. Force quit all instances of QuickLookSatellite

  6. Keep force-quitting until none of them are left

    • Make sure you order processes by name to see them all at once
  7. Restart Finder (see point 2. Restart Finder: again if you forgot how)

Keep having problems?

Since this is now working for me, but in case it still doesn't for you, here are some apps that would normally be suspects but are NOT the cause. This should narrow-down your search:

  • Dropbox (was a problem)
  • Sketch 52.2
  • Principle
  • CraftManager
  • Photoshop CS6
  • Illustrator CS6
  • Bear
  • Highland 2
  • Kindle
  • Atom, PhpStorm, Sublime Text, Caret
  • p4merge
  • Slack
  • Screenhero (don't know why I still keep it)
  • SourceTree
  • Chrome, Safari, FireFox
  • Franz
  • 1Password
  • Spotify
  • Shazam
  • TeamViewer
  • Steam
  • Flux (don't know why I still keep this one either)
  • Microsoft OneNote
  • Bartender 3
  • PSequel
  • Postico
  • GoToMeeting
  • Kaleidoscope
  • MindNode 5
  • Podio
  • Fluid UI
  • Gliffy Diagrams
  • Conceptboard
  • Moqups
  • Wireframe.cc
  • Graph.tk
  • SketchUp, Layout, StyleBuilder
  • Google Keep
  • VLC
  • Trello
  • Asana
  • LiveMinutes
  • Zoom
  • Amphetamine

And remember to clean up useless apps from your laptop. Which I clearly don't.

  • This resolved my issue. Thank you for the thorough instructions. – Amazing Rando Oct 20 '18 at 22:47
  • 1
    After the TL;DR, I had to qlmanage -r again to fix the problem - might help somebody out there... – janniks Oct 22 '18 at 8:42
  • Thank you! It's an reoccurring issue for me. But for now, thankfully, i'm not experiencing the issue, when it happens again i'll try your method. I had luck booting in safe mode and running qlmanage once. – Christian Werther Oct 23 '18 at 7:13
  • Just had the issue again, and this solution fixed it for me. Thanks! – Christian Werther Oct 25 '18 at 13:57
  • You might wanna add Google Drive File Stream app to that list. – vfranchi Jun 13 at 14:08
3

In my case this was caused by Sketch, and update 52 fixes it.

  • This is a great specific error and a great general error. Installing an app can install a new quicklook plug in that would cause all the indexing to be hung up or stopped while it errors out on each file and/or specific file type. – bmike Oct 3 '18 at 14:58
2

Use the following command. It worked for me. No restart required.

sudo update_dyld_shared_cache -force

mac OS Mojave - iMac - Late 2013 - i7 - NVIDIA GeForce GT 750M

1

Had the same issue, but solved it by deleting DropboxQL.qlgenerator inside ~/Library/QuickLook Needs a Finder restart I think

1

Just in case someone is still facing this issue.

After using the command qlmanage -t on an image I found out that Google File Stream app was giving me the trouble.

Terminal screenshot

After deleting Google File Stream app, the QuickLook preview started working again.

  • This is the money answer! if you run qlmanage -t on a file, you'll get the details about why quicklook isn't working. debugging is cake after that! – Mr. T Jun 16 at 7:57
0

I was getting the same problem. I ran the clean my mac, and solved. Not sure what it did. T

  • 1
    Isn't "clean my mac" bad news? – Christian Werther Oct 1 '18 at 13:14
  • Well, I cleaned System cache with Clean My Mac and it solved it 🤷‍♂️ – Ricardo Pereira Oct 2 '18 at 8:24
0

Had the same issue. I booted into Safe Mode by holding Shift upon restart. That must've cleaned up something that was happening because it works great now. No more spinning wheels!

0

There's a dropbox setting that syncs with dropbox that you should switch off from Dropbox preferences. It works perfectly after that

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .