2

While adding a new Google account (G Suite account) to Mail.app (Mac OS High Sierra, 10.13.6), I am able to authenticate successfully but the account is never added to Mail.app. It remains stuck at the screen shown below:

After successful authentication

Appreciate any help on this issue.

  • 1
    I found a solution myself. Go to KeyChain --> login --> All Items and search for "google" keys. Deleted all and then tried adding the account once again when it worked. – Ranjan Sep 30 '18 at 19:32
  • 1
    Hello Ranjan, welcome to Ask Different. Thank you for coming back to add a comment with the solution to your issue. To respect the Q&A format on this site, could you add the contents of your comment as an answer? After a period of two days you will be able to mark your answer as the accepted answer. – jaume Sep 30 '18 at 19:42
  • Per your suggestion, I answered my question jaume. – Ranjan Nov 1 '18 at 7:16
2

I found a solution myself. Go to KeyChain --> login --> All Items and search for "google" keys. Deleted all and then tried adding the account once again when it worked.

  • Thank You so much for this fix. I have been looking for an answer to my gmail issue for over a month now. I first just forwarded my two accounts to two other accounts that still worked in Mail. Though it worked it was not easy to sort out my mail. I just tried your fix and it worked!!! Thank you again. – Mickey May 27 at 17:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .