After upgrading to Mojave, the mac calendar app displays the following error when starting the app.

"server responded with an error"

Is this a problem with Mojave and the gmail server? The error message does not give any further details on the cause of the error.

When I use the mac email app, everything works as it should with receiving and sending emails through gmail.

The attached screen shot shows the error in detail. Error displayed when starting iCal app

  • 2
    all calendars or just specific one?, turn them all of the on one by one
    – Ruskes
    Sep 30, 2018 at 2:20
  • 1
    I'm assuming the gmail one since that's the one I enter all of my events into. Sep 30, 2018 at 11:27
  • 2
    The suggestion by Buscar worked. I was able to get the app to work by de-selecting all of the calendars and clicking on the "revert to server" button. I waited for a minute and selected only the gmail one. All is well now. Oct 1, 2018 at 17:05
  • 2
    OK let me make this an answer so others can find it if they have same problem. All you have to do is accept it.
    – Ruskes
    Oct 1, 2018 at 17:07

4 Answers 4


Try following sequence.

In System Preferences, Internet Accounts, deselect all Calendars to stop the sync.

Wait for a while for the process to stop.

Than click on the "Revert to Server"

enter image description here

Re enable Calendars.

  • 2
    Which option the alert should I click before deselecting calendars (I must click one to proceed)? Wait for which process to complete? How do I prompt the alert without first re-selecting calendars?
    – 2540625
    Jan 29, 2019 at 20:29
  • 1
    It seems to work somewhat, but the triangle with the exclamation mark comes back. Apr 6, 2019 at 16:33
  • Keep in mind that "revert to server" will delete any unsynced event you've added in your local calendar before the last successful sync. Feb 20, 2021 at 6:29
  • 1
    This did not work for me.
    – kris
    Feb 24, 2021 at 1:20

You may need to empty your iCalendar cache. You can find detailed instructions online, but the main points are:

  1. Backup your iCalendar data, particularly if you have locally stored data.
  2. Delete cache files in /Users/$USER/Library/Calendars/ -- basically files with the word "Cache" in the title; there were 3 or 4 files when I did it.
  3. Open iCalendar and reconnect.

Note: This persistent error seemed to start for me when I was performing a Calendar action and had a hard network failure while the action was in progress.

  • 1
    Remember to be patient: It may take a long time to resync the calendar
    – vy32
    May 8, 2020 at 15:27
  • 1
    how do you backup data?
    – John D
    Feb 4, 2021 at 6:23
  • I did this, and immediately after the calendar was sync again I got the same error again...it did not work for me.
    – otmezger
    Feb 23, 2021 at 7:39
  • After doing this the errors go away - but so too have all of my calendars - my google account is listed in the Mac Calendar app, but there are none of my google calendars listed under it.
    – kris
    Feb 24, 2021 at 1:47

I tried the answers posted here with no success. But seems that what have made the Calendar work again, was removing the accounts from the Internet Accounts, restarting the system, and then adding them again.

The entire process was a sum of of the answers here, plus the accounts removal. It was something like this:

  1. Quit Calendar, and kill the CalendarAgent process;
  2. Delete the "Cache" files from ~/Library/Calendars;
  3. Go to Internet Accounts, disable everything;
  4. Restart the laptop;
  5. Go to Internet Accounts again, and remove all accounts;
  6. Restart the laptop;
  7. Go to Internet Account for the third time, and add back all your accounts;
  8. Restart the laptop;
  9. Hopefully Calendar will be working again as mine did and is still doing.

Note 1: Before this whole process, I also tried to delete every file from the ~/Library/Calendars, and that didn't help anything.

Note 2: all my accounts are Google accounts and I didn't backup anything. I have no iCloud or local calendars.

  • This solution lasted 4 days. Yesterday night the error appeared again, so I decided to try a different approach: remove the accounts and add them back, without clearing the cache or restarting the laptop. Didn't work the first time, so my next step was to disable the Calendars in each Internet Account, and enable them again. After 3-4 minutes, the calendars started syncing again! Looking good so far! I might update my answer later. Mar 3, 2021 at 12:11

By deleting all Cache files in the Calendar Libraries (in Catalina), I compromised the software and now iCal no longer runs. I used Terminal cuz I didn't see files via Finder. Careful with deleting files if you are not familiar with the system

  • Which cache files did you delete? What commands did you run?
    – grg
    Feb 24, 2021 at 7:21
  • In Bug Sur, removing cache files made iCal fail, correct, but after I've removed all accounts in Internet Accounts and re-created them iCal started working again. As others mentioned resync takes time you may see empty calendars for few mins.
    – ggat
    Feb 26, 2021 at 8:07
  • command: rm- "*cache". Turned out that after like 30min of attempts at re-sync, iCal in Catalina eventually "rebooted" and started to work again. However, the “server responded with an error” resurfaced and remain a constant problem. Mar 1, 2021 at 16:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .