1

I have an old iMac on MacOS 10.13 High Sierra with the standard Magic Keyboard (before the current MK2). I normally use the iMac in Target Display mode, and then use Screen Sharing from my newer iMac to connect to it when I need to do something directly on the old machine. Naturally, I use the newer keyboard attached to my newer iMac.

A few days ago, I found that most of the keys on the old iMac appear not to be working. After a lot of testing, I can say the following:

  • The old keyboard connected to the newer iMac works well
  • An alternative Bluetooth keyboard connected to the old iMac also has the same problem
  • An alternative Wired keyboard connected to the old iMac also has the same problem
  • Everything is fine when I enter using the newer iMac keyboard on screen sharing
  • I have ensured that mouse keys and slow keys are turned off

All this suggest that there is a software problem.

I had it working for a while. I then restarted, and it worked for a while longer. Now it’s gone back to the problematic behaviour, and I can only type the a key, for some reason.

Any suggestions?

  • what os x is on it ? – Ruskes Sep 29 '18 at 5:46
  • MacOS 10.13 High Sierra. It won’t support Mojave. – Manngo Sep 29 '18 at 5:47
  • did you try to refresh the driver on iMAC for the Magic keyboard ? also I suggest you run the EtreCheck and see what is says. – Ruskes Sep 29 '18 at 5:48
  • when you connect the alternate wired/BT keyboards, do you disconnect (i.e. turn off) the old keyboard? – Allan Sep 29 '18 at 12:08
  • @Allan I have now. Same thing … – Manngo Sep 29 '18 at 12:35
1

Thanks to your investigative work, it appears that the common problem is the Bluetooth on iMac.

Try resetting you BT.

You will loose paring so you have to pair it again.

To reset BT hold Shit+Option and click on the BT icon in the menu bar.

Now you will see the Debug menu.

  • This is really weird. I reset Blutooth and removed all of the devices. I then reconnected the keyboard which involved typing in a 6-digit number. After that, the keyboard doesn’t work again, including the numbers I just typed in. Only the letter a. The same applies to a 3rd-party bluetooth keyboard. I can enter the number for pairing, but only the a works after that. – Manngo Sep 29 '18 at 7:37
  • Thanks for your suggestion. I have also tried a wired keyboard and get the same problem, so it’s not bluetooth. Still have no idea. – Manngo Sep 29 '18 at 8:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .