0

I just finished installing macOS Mojave on a brand new 2018 MacBook Pro.

One of the first things I usually do is disable all unnecessary fonts.

This time, the option to disable the font is grayed out for every single font.

In the Finder the file permissions are as follows:

system: Read & Write
wheel: Read only
everyone: Read only

How can I disable fonts in Font Book on OS X Mojave?

  • it was like that on HighSierra as well – Ruskes Sep 28 '18 at 21:00
  • I have been using High Sierra for a year and it's been fine. Did the problem go away eventually or did you never solve it? – Andrew Swift Sep 29 '18 at 2:30
1

It seems like Font Book in Mojave won't let us disable any fonts located in /Library/Fonts, where fonts are supposed to be installed for system-wide use. But I can disable/enable fonts with Font Book if they're located in ~/Library/Fonts (inside your user's home folder).

If you take the other suggestion to make a new folder called /Library/Fonts (disabled) or /Library/Fonts Disabled or /Library/Fonts I Hate etc, moving any fonts into there will just make them disappear entirely out of Font Book. It's not exactly disabling them, it's just putting them into a place where Font Book isn't looking for fonts at all.

Better to move any unwanted system fonts into ~/Library/Fonts, at least they will still be visible to Font Book, and you can easily enable them again if needed.

  • The usual reason for wanting to disable fonts is to remove them from the font menus of your apps. The procedure you suggest will not do that. – Tom Gewecke Feb 20 at 4:30
  • I think this is a great idea, and I would have suggested it if I had thought of it. Tom, this technique will remove them from the menu once you deactivate them (the whole reason for this post). – Andrew Swift Feb 20 at 8:22
1

It turns out that (as far as I know), Font Book in Mojave just does not allow disabling of the default fonts.

There are two main locations where fonts are stored under Mojave:

/Library/Fonts/

/Library/Fonts/ contains all the general use fonts, available to all users. These are the fonts I wanted to disable.

/System/Library/Fonts/

/System/Library/Fonts/ contains fonts that are necessary for the system.

I simply moved all the fonts from /Library/Fonts/ to /Library/Fonts (disabled)/

It went fine and the system has not complained so far.

I did leave copies of the standard web fonts: Verdana, Times New Roman etc.

  • Thank you very much Andrew. Your method of manually moving the font worked for me. – Mret Nov 17 '18 at 5:19
0

Select all the fonts you want to remove

and drag the over under Collection in a new folder.

Now you can delete or disable all fonts in that folder !

  • Disable is still grayed-out. – Andrew Swift Sep 29 '18 at 2:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .