After updating to Mojave my system crashes. It can only be started in safe-mode.

According to crash logs from sysdiagnose, a particular extension is causing problems:

0xffffff811b0f3fa0 : 0xffffff800c9590ce
  Kernel Extensions in backtrace:
      dependency: com.apple.iokit.IOStorageFamily(2.1)[499E27C9-AC4D-3239-9FC4-754C7699FA76]@0xffffff7f8d704000

It seems the extension can be found but not removed

$:/Library/Extensions$ kextfind -b com.coriolis-systems.driver.Snapshot
$:/Library/Extensions$ kextunload -b /Library/Extensions/CoriolisSnapshot.kext
(kernel) Kext /Library/Extensions/CoriolisSnapshot.kext not found for unload request.
Failed to unload /Library/Extensions/CoriolisSnapshot.kext - (libkern/kext) not found.

How do I remove this extension completely? It also shows up under /Library/StagedExtensions/Library/Extensions and /Library//SystemMigration/History/Migration-XXX/QuarantineRoot/Library/StagedExtensions/Library/Extensions/

For that matter are there any way to just remove all third-party extensions without a fresh install?

-- UPDATE --

After losing patience I just removed the /Library/Extensions/CoriolisSnapshot.kext directory after having started in safe-mode. The system booted successfully into Mojave and then opened notification windows indicating several third party extensions were blocked. After allowing one to load the security and privacy pane opened where I was able to check/uncheck other extensions. The Coriolis Systems box was there and I left it unchecked. The system then restarted successfully without any more requests.

Fair warning! This was somewhat risky. Removing system folders can have unintended consequences. The only reason I was willing to try was that I made a full disk image backup just prior to installing Mojave.

  • try rm file name in Terminal
    – Ruskes
    Commented Sep 28, 2018 at 21:20
  • Simply removing system extensions with rm is risky because they may have dependencies. The only reason I tried it was that kextunload didn't work and I was prepared with a backup.
    – John D.
    Commented Oct 1, 2018 at 16:23

3 Answers 3


As the developer responsible for that KEXT, I'm sorry that it's crashing. You did the right thing just deleting it; it isn't going to be updated for Mojave (because, frankly, there's no point; what with APFS and the various security changes, I'm afraid iDefrag is now a legacy-only product).

For anyone else seeing this problem, you can boot into Safe Mode by restarting your machine and holding Shift (the key marked ⇧) when you hear the boot chime. Alternatively, you can boot into Recovery Mode by holding Command (⌘) and R when you hear the chime; if you're in Recovery Mode, you can open Terminal from the "Utilities" menu at the top of the screen.

To delete the KEXT, follow the instructions below:

From Finder

  1. In Finder, choose "Go to Folder…" from the "Go" menu.

  2. Enter /Library/Extensions into the box that appears.

  3. Press "Go" (or hit Return).

  4. Drag the CoriolisSnapshot.kext to the Trash (or choose "Move to Trash" from the "File" menu).

From Terminal

  1. Enter sudo rm -rf /Library/Extensions/CoriolisSnapshot.kext at the prompt, and press Return.

  2. If prompted, enter your password and press Return.

  • I'd like to kindly ask you to add warning to Coriolis' page about iDefrag messing up a newer macOS. Also instructions on how to remove kexts in the same place would be helpful. Did I understood right, that kexts have to deleted in Recovery or Safe Mode?
    – toke lahti
    Commented Jan 15, 2023 at 16:13
  • One does not have to boot into 'Recovery' or 'Safe Mode' to delete kernel extensions (kexts) from '/Library/Extensions'. (If a system will not boot, however, then deleting from either the recovery environment or while in 'Safe Mode' will work as well.) Commented Aug 12, 2023 at 6:21
  • In this case the system won’t boot with the extension installed, so you do need to use Safe Mode.
    – al45tair
    Commented Aug 25, 2023 at 15:38

To remove the files inside Library/StagedExtensions/Library/Extensions/, open Terminal and type sudo kextcache --clear-staging and the files will be erased. To make sure they get completely removed, reboot your Mac. Also, this doesn't require you to disable SIP.


I found it by myself! Thanks to Alastair to making me going a bit deeper into reasoning why removing physically everything still gave me the error.


It is much more important than trying anything else. I cannot believe Apple made it so mindblowing to use the "evoluted" way, as they put MacOS much more into "children playing games" OSes...

So, my solution is:

  • booting into Recovery Mode by holding Command (⌘) and R when you hear the Mac's chime (as previously stated by Alastair); then from the Utils menu choose Terminal and type csrutil disable. type reboot or reboot by the specific menu.

  • If you also need to clean some cache, I found also some few lines useful for Hackintoshes, but by using the same Recovery Mode, you can go here: https://www.tonymacx86.com/threads/rebuilding-kernel-cache-in-catalina.285643/

Not all commands work (Gatekeeper is useless in Recovery Mode, isn't it?), but I tried some and nothing gone wrong... at least it says that it cannot be done or files are non-existing...

Cross fingers and reboot: works! Thanks guys, whatever you wrote for anybody lurking around. It saves headaches to many of us!!!

Long live and prosper, Happy Easter.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .