0

All of a sudden this morning my extensions stopped working. The extensions preference pane is empty and says "No extensions".

All the extensions are left in ~/Library/Safari/Extensions, and if open one of them to install it says (roughly translated):

Safari can not install this extension

An error occured when the ”NinjaKit” extension was installed.

I tried restoring the entire ~/Library/Safari folder and ~/Library/Preferences/com.apple.Safari.plist from a backup from yesterday when everything was working fine, but that did not solve it.

The issue may stem from wrong permissions somewhere, since if I try to edit the Extensions.plist file manually it says "Unlocking failed for an unknown reason." when I try to save it. I tried sudo chmod -R 0777 ~/Library/Safari/Extensions but that did not solve the issue either. The file is not locked from the "Get Info" view in Finder.

  • Safari has most probably been updated to version 12, which doesn't support NPAPI extensions, see last paragraph at developer.apple.com/safari/whats-new and my answer to a similar question (apple.stackexchange.com/a/336848/32815). – jaume Sep 28 '18 at 12:46
  • @jaume I forgot to mention that. I read about that update, and it would be a very logical explanation, but it's still actually on Version 11.1 (13605.1.33.1.2). I still think it's a permission error, because I noticed now that it doesn't record any history either, and despite having browsed all day, the edit date for the history database file is still from yesterday. I'm going to update to Movaje soon anyway, so I may as well stop using .safariextz.. – DisplayName Sep 28 '18 at 13:14
0

The permissions issue ended up being the problem that prevented me from using extensions.

For some reason, it keeps the weird time machine permissions (you can't edit a time machine backup etc.) when I copy over the Safari folder through Finder. It shouldn't do this and never has for me before this.

But I solved it by instead copying it over through the terminal, using cp, which doesn't preserve any metadata unless I specify that it should do that. After doing that, I had to reinstall the extensions (and thus lost some extension data) but at least they work now.

EDIT: I was able to recover the lost data, from a backup of ~/Library/Preferences/com.apple.Safari.Extensions.plist

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .