10

enter image description here

I know this's been asked a lot, but I really tried everything, but still no luck to get the thumbnails back. Here's what I already did:

  • Regenerated Finder related .plist files;
  • Toggle on and off the "Show icon preview" button;
  • Drag things to the icon of "Get info" then deleted it;
  • Reinstalled Mojave;
  • Tried to revert back to High Sierra with Time Machined, but the backup is probably corrupted.
  • Reinstalled Mojave, use Migrate Assist to refill the user files;
  • qlmanage -r enable

  • Other sudo commands.

NONE of that worked! You can imagine how desperate I am right now. I'm a designer, and I need those thumbnails to identify the files.

Only when I created a new user account, it almost worked. The thumbnails loaded properly for a short period of time, but after reboot the machine they're gone.

If you can provide other solutions I'm really willing to try. Thanks!!

Updates: After testing with another admin account, I find out it might have something to do with the QuicklookSatelite process. Compare to the test account, this process just won't load when needed, I'm still trying to find out what is keeping it from working.

Updates2: Thank you! Thank you all for everything! It is indeed caused by Sketch, never thought a software can cost so much trouble. Thanks for helping me!

  • did you associate those file – Ruskes Sep 28 '18 at 4:10
  • It’s not just those files, every type of file can’t show their thumbnails somehow... – Amyas Marshall Sep 28 '18 at 4:12
  • what does it say when you right click and say open with... does it gives you list of choices, which one is set as default – Ruskes Sep 28 '18 at 4:15
  • It says preview. And every other files are set to their correct open method. – Amyas Marshall Sep 28 '18 at 4:20
  • Just did, it but didn't helped. It's so wried, after I created a new user, the thumbnails started to load one by one, but after a few seconds, it stopped, and after the reboot, the loaded thumbnails are gone. Not sure it have anything to do with com.apple.IconServicesAgent, since I can't find this service in the console or anywhere else. – Amyas Marshall Sep 28 '18 at 4:33
7

Sketch is making that issue. You can try it, delete sketch and all thumbnails will appear instantly.

I have reported a bug already.

  • Thank you!! I switched back to my old computer running Hight Sierra this morning, I'll try it as soon as I got home. Thanks again! – Amyas Marshall Sep 29 '18 at 2:28
  • Yes, Sketch is making that issue. i've deleted the app and my the thumbnails showed up. – Youssef Rina Sep 29 '18 at 10:15
1

This issue has been resolved with the Sketch v52 update released today, as explained in its release notes (click View All and scroll down to the Bug Fixes section):

Fixed a bug where Quick Look previews weren’t generated when saving Sketch documents

You must log in to answer this question.

protected by Community Oct 3 '18 at 23:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .