11

This notification keeps appearing on my Mac running Mac OS X 10.13.6 (17G65):

Notification that Wi-Fi calling is available

Wi-Fi Calling
You can use your phone number to make and receive calls directly on this Mac using Wi-Fi.

I have:

  1. Clicked "Not Now"

  2. Clicked "Turn On"

  3. On my Mac: Turned off all notifications for FaceTime

  4. On my Mac: Logged out of FaceTime

  5. On my iPhone: Went to "Settings" » "Phone" » "Wi-Fi Calling" and turned off "Add Wi-Fi Calling for Other Devices"

  6. On my iPhone: Went to "Settings" » "Phone" » "Wi-Fi Calling" and turned off "Calls on Other Devices"

Still, after all of that, the notification keeps coming back every few minutes.

Any ideas how to kill this thing?

I tried Google but all of the results were about turning this feature on, not off.

0
3

The answer appears to have been this:

Turn on the feature on my iPhone.

Wait awhile.

Turn off the feature on my iPhone.

Reboot the Macs that were showing the notifications.

One of those things made it go away.

0
2

My Mac kept nagging after configuring a new iPhone. Despite turning WiFi calling on on the Mac, and rebooting, the nags kept re-appearing.

What finally caused a stop was updating my E911 emergency contact on the phone. No more Mac nags!

1

I recently upgraded to the iPhone 12mini (from iPhone 6s) and was receiving this issue. After some poking around, here's how I was able to solve it:

  • Sign out of iMessage / FaceTime on your old iPhone.
    • Or more drastic, erase all content and settings from your old iPhone.
  • Sign out then sign back in to iMessage and FaceTime on your new iPhone.
  • Authenticate / allow wifi calling from new iPhone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .