5

When I shut down, restart, or update and restart my mac goes about shutting applications down to get ready to turn the computer off as it normally does but after my top bar and desktop icons have gone away it just stops.

Its just a dock and a wallpaper, the only application that's open is Finder which is stuck in a half-closed state that no amount of relaunching will fix.

While trying to fix this glitch disk utility also went into a state of refusing to force quit and freezing.

When it's in this glitched state I can start opening up applications and use them like normal although they sometimes get a bit buggy especially if they need major graphics card usage.

I can shut my mac down after this in three ways, hold down the power button, unplug the computer, or use the command shift - command - power. But when I try to update my mac and click restart and then do one of those three methods the update doesn't get installed.

So far I've tried resetting the VRAM and booting into safe mode neither of which have worked. Please help I'm desperate.

Im using Sierra currently on a 2015 iMac

  • I do not think it is the Finder, that is what you see, but something else. – Ruskes Sep 28 '18 at 2:16
1

There are 2 tools I recommend to use to narrow it down.

One is called EtreCheck (you have to download it)

The other is built-in system check from Terminal. The following command runs system diagnostics and creates a text file.

sudo sysdiagnose -f ~/Desktop/

It might take 5 minutes but creates complete report.

We could also just look for it in the Console. For that you need to note exact time when you try to shut down. Now go to the time stamp in the Console and see what it says.

  • Should i run this in the glitched state or just as normal? – Skyler Young Sep 28 '18 at 2:09
  • if you can run in glitched state then do so – Ruskes Sep 28 '18 at 2:23
  • i ran it in the glitched state but i cant access the file until i restart my mac – Skyler Young Sep 28 '18 at 2:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .