8

As the title suggests, when I run the command /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport en0 sniff 6 in Terminal where en0 is my Wi-Fi interface and 6 is the channel I am sniffing; I am now getting an error message reading Segmentation fault: 11 almost instantly. This has never been a problem before updating to macOS Mojave (10.14) but is a reoccurring problem with the new update despite reboots, NVRAM resets etc.

My question is: has anybody else experienced this problem before? If so, are there any solutions or is it something that we must hope Apple will fix in a future release of macOS?

Thank you in advance for any help,

Kind regards, Tom

  • were you able to fix this, I'm having the same problem on 10.14.1 beta – acrogenesis Oct 12 '18 at 0:20
  • @acrogenesis Unfortunately not. Hopefully it's something which will be fixed in a future release of Mojave. For now, I'm using tcpdump as suggested below but would like to move back to the airport command as soon as possible. – Tom Oct 12 '18 at 0:38
2

I faced with this problem, when try to dump traffic from interface. Possible solutions:

  • use tcpdump with writing to file, like suggested below
  • use Wireshark for capturing traffic from this interface
  • Thanks for your answer! I was aware that other tools like the ones you mentioned were capable of dumping traffic; however, my question pertained to the fixing of the problem with the airport command in particular. Either way, thank you for suggesting tcpdump as a reasonable alternative for anyone else looking in the future. I too, will be using tcpdump until Apple fixes the airport issue. Thanks once again! Best – Tom Sep 30 '18 at 11:35
  • Sadly, airport seems to be the only option to sniff specific multicast messages. This worked fine with airport, but these messages does not show up when using tcpdump or wireshark. – Bitbored Oct 29 '18 at 15:04
  • 1
    How are you using tcpdump in exchange of airport en0 sniff 6? – acrogenesis Mar 26 at 15:51
0

I recently found an executable file on /usr/libexec/airportd, it works properly as previous versions.

  • Good find, however I'm still having the same problem. Even if I run /usr/libexec/airportd en0 sniff 6 I still get the same Segmentation fault: 11 error – Tom May 27 at 10:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .