1

In the process of upgrading a 2 4tb disk RAID 0 array from an iffy LaCie drive to a faster/more reliable USB enclosure I have lost data. The backups take a long, long time to restore so I'm hoping to be able to rebuild the RAID 0 array instead. This is all on a Mac Mini running High Sierra.

It was originally a RAID 0 array in a LaCie Thunderbolt drive, but this kept randomly dropping out so I decided to move the drives into a COTS USB 3 enclosure instead. This was set up as a RAID 1 array with 2 2tb drives and I cloned the LaCie contents onto it as a backup. Then I took the pair of 4tb drives from the LaCie and put them in the USB enclosure and switched it to RAID 0 mode, but the Mac Mini did not recognise them. So then I replaced them in the LaCie enclosure, but they just showed up as 2 different drives which the Mac Mini would not mount. I tried switching the order of the drives, but this did not help. I wasn't worried because I still had my pair of 2tb RAID 1 drives, which I put back in the USB enclosure, switched it to RAID 1 mode and...the Mac Mini would not recognise it. Data gone - and I hadn't even done a single write operation or formatted anything.

I have tried Data Rescue and 321 Soft Raid Recovery to try and recover the LaCie RAID 0 drive, and while I have managed to get a lot of data from the RAID 1 drive, it's just recovered it as a bunch of files with no usable filenames or directory structure.

My offsite backups appear to be incomplete, and in any case are taking literally days to restore.

distil list output: ...$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            999.3 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

/dev/disk4 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *5.0 TB     disk4
   1:                        EFI EFI                     209.7 MB   disk4s1
   2:                  Apple_HFS HSBACKUP1               5.0 TB     disk4s2

/dev/disk5 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                                                   *4.0 TB     disk5

/dev/disk6 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                                                   *4.0 TB     disk6

/dev/disk 5 and 6 are the elements of the RAID 0 (ignore HSBACKUP1 - that is my offsite backup drive currently doing a restore of most of the company files)

My LaCie enclosure model is a 2big thunderbolt 8tb - comes preconfigured as RAID 0. I didn't install it originally (it was done in 2013) but I assume it was just used with default settings.

So - does anyone know how to rebuild a RAID 0 array on a mac? It hasn't been formatted or written to in any way - just put into another enclosure, taken out and put back into the original.

OUTCOME: Have not succeeded in rebuilding the RAID. Instead between the restores from my offsite backups and £60 for a Data Rescue license, have managed to recover everything that was lost. Lessons learnt: do not use a Mac as a file server, with the best will in the world they're just not built with that in mind, and verify your daily backups to make sure they're backing up everything you need them to, I wouldn't have had any problems at all save that the account doing the backups did not have rights to all the source files.

  • What controller runs the RAID? Some LaCie devices have a firmware raid controller. Disk Utility on Mac OS can make a software RAID. There are many this party soft raid solutions as well (softraid.com) - Can you edit your post to be super clear what the output of diskutil list is and also exactly what model LaCie makes the RAID stripe 2 disk set of 4 TB disks - maybe a drawing how things connect would help us help you. – bmike Sep 27 '18 at 11:44
  • Thanks - away from desk but will post data when back. – dartacus Sep 27 '18 at 14:59
  • Updated question with distil output and LaCie model. Assume the raid controller is S/W as the packaging advises it can be reconfigured via Disk Utility and there are no hardware controls to switch mode. – dartacus Sep 28 '18 at 9:18
  • Nice edits! I've removed all the "meta" - EDIT - see how the system tracks each edit - I've just tried to make the facts be there. Sadly, you're still out of luck - LaCie controllers did the RAID so you'll need to get those drives to software that knows how to repair that or get help from them in all likelihood if you don't seek someone who does recovery professionally. – bmike Sep 28 '18 at 13:35
2

All consumer file recovery software I've seen and evaluated do exactly what you say. They troll each and every block of the drive and make up stories and file names in the presumption that each block was a file that's now deleted.

Someone has to spend tons of time pouring over each and every file to make sense of them or start looking for metadata (social security numbers, passwords, ascii strings / hex values) and then report how much progress is made finding needles in the haystack.

Normally if you send in drives from a JBOD type RAID to a recovery service - they offer free quotes and can speak much more intelligently about your prospects and if this is a $500 recovery or a $5000 recovery effort.

In your specific case, if the LaCie drive comes RAID 0 by default, there's nothing on the macOS side that made the decision where to store the data - it's all embedded in the firmware shipped by LaCie so your first stop would be to ask them for technical assistance or documentation to see if you can rebuild how they stored the data.

Your diskutil list shows clearly that the drives now aren't seen as a RAID so your diagnosis is correct and you'll want to get software that supports LaCie RAID recovery or hopefully find someone that reverse engineered and documents how to do this. I haven't ever seen such a thing and usually pay if the business need is more than just walking away from the data that wasn't backed up in a way it can be restored easily (or at all).

  • Thanks bmike. I had suspected as much. Will raise this with LaCie as advised, hopefully they have some manner of recovery tool. – dartacus Sep 28 '18 at 15:19
  • 2
    For the record, LaCie just direct customers to a standard Seagate recovery tool, and I had already done a standard file recovery. In any event my backups contained 99% of what I needed and the recovered files filled in the rest, so bullet dodged this time. – dartacus Oct 4 '18 at 10:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .