1

My situation is a bit complicated. I have an iPhone SE with iOS 9.3.5. I connected my iPhone to a rental car's audio system and something bad happened. The lock button stopped working and it is spontaneously "clicked" (software-wise) randomly. Sometimes I even get the turn-off screen that is usually displayed after a long lock-click, expect I don't press anything. I've tried to do a force-reboot (holding the lock and home buttons for a few seconds), the iPhone get turned off, but then immediately it gets into a loop, and the only way to get it to load is to connect it to a power source. This happens also after I simply turn it off (using the accessibility software solution). I now back-upped the phone to my iTunes, and deleted all of the data so it'll be new-like but this did not help the problem. All of the above symptoms are still happening. Any ideas on what else I could do?

2

I don't think this is related to plugging into the rental car.

I also have (had) an iPhone SE and it experienced the exact same problems. I took it in and was told the sleep/wake button on top was bad. The repair place told me they don't bother repairing these models anymore because the parts are very hard to find; this model has a bad problem with this type of button failure. If you google it you'll see.

I ended-up going to Best Buy and they recycled it for free. I think you're out of luck unless you can find a place to repair it.

  • It seems weird to me because this happened right after I connected it to the audio system of the car. Then I managed to fixed by some resets, and after plugging it again to the car (stupid action) it happened again. Now I'm not sure if I should do an iOS update to iOS 12 and see what happens. – bobsacameno Sep 27 '18 at 7:16
1

I just got back from a repair shop and they just solved the problem. I'm not sure exactly what it was - but now it solved. I still think it was a software issue since they thought that the button must be replaced at first, but eventually they didn't replace it.

The only think that's annoying at this point is that I thought that erasing the iPhone would help (since I read it online in a few blogs). It didn't help, and now I cannot install some of my apps because they are unavailable for iOS 9 anymore. So my advice: in this kind of case - first go to a repair shop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .