When I close my MacBook Pro in the evening, and then open it in the morning, the display is illuminated and the apple is bright but nothing is happening. So I need to push the power button to restart it. When it restarts, Google Chrome crashes and virtualenv is logged out.

I thought that the problem is with hibernation so I set the hibernation to 0 in pmset. My current pmset parameters are as follows:

 standbydelay         10800
 standby              1
 womp                 1
 halfdim              1
 hibernatefile        /var/vm/sleepimage
 powernap             1
 gpuswitch            2
 networkoversleep     0
 disksleep            10
 sleep                1
 autopoweroffdelay    86400
 hibernatemode        0
 autopoweroff         1
 ttyskeepawake        1
 displaysleep         10
 acwake               0
 lidwake              1

2018-10-05 12:50:03 -0700 Assertion status system-wide: BackgroundTask 0 ApplePushServiceTask 0 UserIsActive 1 

PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 0 PreventUserIdleSystemSleep 0 NetworkClientActive 0

Listed by owning process: pid 94(hidd): [0x0000000e00098030] 00:00:00 

UserIsActive named:"com.apple.iohideventsystem.queue.tickle.4294968174.3" Timeout will fire in 600 secs Action=TimeoutActionRelease pid 188(mds_stores): [0x00000115000b80fd] 00:00:00 

BackgroundTask named: "com.apple.metadata.mds_stores.power" 

Kernel Assertions: 0x100=MAGICWAKE id=503 level=255 0x100=MAGICWAKE mod=31.12.1969, 16:00 description=en0 owner=en0 

Idle sleep preventers: IODisplayWrangler

If I close the lid shortly everything is okay. Any ideas on what is going on?

  • 2
    It's probably an issue with your sleepimage. Issue the command sudo rm /var/vm/sleepimage and see if that fixes the issue.
    – Allan
    Sep 28, 2018 at 15:06
  • 1
    What exact model off MacBook Pro do you have?
    – Monomeeth
    Sep 30, 2018 at 3:35
  • 1
    also run pmset -g assertions in terminal and tell us what it says
    – Ruskes
    Oct 2, 2018 at 5:02
  • 1
    I've just posted an answer, but in doing so have realised that we don;t know what version of macOS you're running? Also, have you got FileVault enabled?
    – Monomeeth
    Oct 3, 2018 at 0:32
  • 1
    Thank you for posting more info. I had a typo, "Initiated" not imitated. So now we see you have MAGICWAKE running. Why ? Turn it off. The Console log is in your Utility folder > Console.
    – Ruskes
    Oct 5, 2018 at 22:24

7 Answers 7


As you probably know, troubleshooting is a process of elimination and often requires patience. There's a few things I would try to get to the bottom of this.

The first things I'd try are to reset both the NVRAM and SMC in that order. Before following the steps below, ensure you have no external hardware connected and make sure you use the built-in keyboard.

Reset the NVRAM

Older Macs had what's called Parameter RAM (PRAM), newer Macs use Non-Volatile Random-Access Memory (NVRAM). Here’s how to reset the NVRAM on your particular MBP:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Once completed, proceed to resetting the SMC (see below).

Reset the SMC

To reset the SMC on your particular MBP, follow these steps:

  1. Shut down your computer
  2. Keep the power cable plugged in.
  3. Press at the same time shiftoptioncontrol (on the left side of the keyboard) and the power button and keep all these pressed down for at least 10 seconds.
  4. Let go
  5. Turn your computer back on with the power button.

After resetting both the NVRAM and SMC, use your computer to determine if it still doesn't wake up after sleeping for several hours.

If the problem persists, then try booting into Safe Mode to test again (see below).

Boot into Safe Mode

Follow these steps to test your Mac in Safe Mode:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. use it normally and then let it go to sleep for several hours and test to see if it wakes up okay)
  6. If it works okay, exit Safe Mode by restarting your Mac as normal. If not, force start your Mac again.

If your MBP still doesn't wake from sleep properly, then it's time to test your hardware with Apple Diagnostics.

Run Apple Diagnostics

Follow the steps below to run Apple Diagnostics:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the D key and keep it down until you see the Diagnostics screen appear
  4. Wait for Diagnostics to finish (this typically only takes a few minutes)
  5. Once complete, one of two things will appear on the screen:
    • a No issues found message
    • a brief description of any errors found plus further instructions
  6. If the diagnostics test does find errors, take a note of what they are

Note: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

Regardless, take a note of what happens and let me know how you went.

  • 1
    thanks, man! I have already tried resetting NVRAM and SMC. Unsuccessfully. May be I did it wrong. I will give it a try again. I did not tried Safe Mode yet. Will try it if resetting NVRAM and SMC will not work. I have already run diagnostics. No issues was found. I will keep you informed.
    – doubts
    Oct 5, 2018 at 18:52
  • 2
    @doubts where's the inform?
    – digout
    Feb 27, 2019 at 17:36
  • Thanks for this! I have a similar issue with my MacBook Air (Intel, 2020) not waking from sleep after a night of being stored with the lid closed. I reset the SMC and now everything is fine again. Apr 5 at 2:30

Recommend to evaluate the Sleep mode.

Run pmset -g assertions in terminal and post the output.

Usually you can see there who is acting up and not letting your mac sleep.

The message Kernel Assertions: 0x100=MAGICWAKE id=503 level=255 0x100=MAGICWAKE says it.

Also the ExternalMedia is set to wake it up over your USBbluetooth. connection.

So you have a device (BT keyboard) that does that.

As for why:

You BT track pad wakes up (do you have a Cat?) other BT devices interference, low battery... see this for more.

To test do "Allow Bluetooth devices to wake this computer" OFF.

If you have the Magicwake app installed, remove it.


So I've tried everything and I Mean everything. Have taken it to apple 4 times. reinstalled 4 times, nothing works..

Turns out it has to do with iCloud Drive not allowing the Hard drive to shut down or sleep properly. Turn off iCloud Drive on device.


There is a known issue with the Macbook Pro Mid 2015 waking from sleep. There isn't a single solution, but there is an Apple article about it. The short version is to disable power nap on the "On Battery" and "Plugged in" power save settings in System Preferences.

  • Only if you replaced SSD and this has been fixed in Big Sur.
    – Marek H
    Aug 1, 2021 at 9:20

I started experiencing this issue (on MacBook Air 13-inch, Mid 2013) after upgrading the SSD (OWC Aura pro). It turns out it was only happening when waking from deep sleep/hibernation, and only when it hibernated on battery. Weird eh?

Welcome to the apple/unix command line utility pmset, complete with its own man page. I used pmset to turn off disksleep when on battery (AC profile does not even use it). To turn off disksleep, you must also turn off sleep.

This is not stopping the Mac "black screen of death" so far but it seems to the right track.

I would guess the aftermarket SSD is crashing when it gets the powerdown` signal normally associated with hard disks, because it is slightly different than the apple SSD.


sudo pmset -b sleep 0
sudo pmset -b disksleep 0

One thing I will be watching for is this getting reset by changing the energy preferences in Control Panel.


What worked for me was recreating the sleep image.

sudo rm /var/vm/sleepimage

I think an error in sleepimage maybe was preventing wake and shutting the laptop.

Also I created a new user and deleted the old user.

Till now it's working fine.

Prev shutdown logs used to show a -2 code and I can't seem to find description of it anywhere on official apple site.


What works for me is pressing Ctrl+Option+delete until the cursor starts blinking again on the sign-in page.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .