1

My MacBook Pro (Retina, 13-inch, Late 2013) started freezing every time I boot it.

I've tried resetting the NVRAM and SMC, and have even reformatted it.

After doing that, I noticed that if I kept moving the mouse (trackpad or external mouse), my computer would no longer freeze. However, if I stopped moving the mouse, then the computer would freeze again.

The computer doesn't have this behavior if I start it in Safe Mode.

How might I troubleshoot this further?

Edit: When I was trying to copy the log from Console, I had to move the cursor or the computer would freeze. But after I open Safari, I could stop with no issue. I shift tabbed on Console and then the Mac froze again!

Edit 2: After some test, I figured out new strange behaviors. If something is moving on my screen, no freeze.

I was on Youtube, and I played a video > no freeze during the entire video. I stopped the video > freeze after 2s.

I tried something else: I launched another video then I minimized the window > freeze after 2s, but I could still hear the sound.

It's like the computer's freezing only if nothing is moving on the screen.

  • Open console in Utility Folder, then monitor it, then stop moving (but remember the time down to a second) the muse, and see what it reports, copy the lines from the moment you stopped and the following 50 lines, then report here – Ruskes Sep 26 '18 at 7:07
  • I tried that already. There is absolutely nothing at the time it freezes. I guess even the logs are not saved? – Cyril F Sep 26 '18 at 7:24
  • I can not know what you tried ! As for the logs, the system logs everything just need to know how to look for it. Freezing is a big event. But since you do not want to post the log, I can not help you. – Ruskes Sep 26 '18 at 7:34
  • 1
    If this is still an issue after reinstalling MacOS you might have a hardware problem. – Thorbjørn Ravn Andersen Sep 26 '18 at 7:48
  • 1
    If you run into similar issues with different freshly installed versions of maxOS it probably is hardware, not software. – nohillside Oct 2 '18 at 5:15
-2

From your Console log, the last event before reboot was the

Sep 26 03:35:00 Ashleys-MacBook-Pro com.apple.xpc.launchd[1] (com.apple.bsd.dirhelper[379]): Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.bsd.dirhelper

What is Dirhelper

http://www.manpagez.com/man/8/dirhelper/osx-10.6.5.php

Possible solution..

Copy Dirhelper Plist as safety precaution located in

/System/Library/LaunchDaemons/com.apple.bsd.dirhelper.plist

Then delete it.

Restart

You can also try Safe mode to isolate the issue..

What safe mode does...

Verifies your startup disk and attempts to repair directory issues, if needed
Loads only required kernel extensions
Prevents startup items and login items from opening automatically
Disables user-installed fonts 
Deletes font caches, kernel cache, and other system cache files

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .