14

Even with “Reduce transparency” enabled, Mojave’s desktop-tinting is quite horribly annoying, in both Light Mode and Dark Mode (regardless of accent color). Switching to a solid red desktop background, for example, results in this ugly appearance of the Dock, notifications, some popups, and the Finder sidebar:

Dock with desktop tinting Notification popup with desktop tinting Popup tooltip with desktop tinting Finder sidebar with desktop tinting


An earlier answer claims that using Light Mode or using the Graphite accent disables desktop-tinting, but that’s untrue.

Is it possible to disable desktop-tinting with Reduce Transparency in macOS Mojave?


I reported this as bug #44861849 to Apple, and they closed it as a duplicate of bug #43428401 on 2018-10-19, which is open as of this writing. However, I encourage others to create bugs, as it may increase the priority if more users report.

This is still an issue with macOS 10.14.1.

  • 1
    This drives me crazy as I use to have a changing random picture as my desktop wallpaper. I was searching everywhere, please report back if you find any reasonable solution. Every major MacOS release nowadays just seems to add a bunch of useless features and make the OS more restrictive and closer to iOS. Annoying. – danielv Sep 27 '18 at 7:41
  • I hate it, too. The only option that seems to turn that off completely, is the "Increase cotrast" checkbox. But that obviously adds a contour to everything. – Adam Hošek Sep 28 '18 at 8:23
  • Seriously, one of the ugliest things about Windows 7 was the transparency which made the whole desktop look like looking through dirty windows. They got rid of that in Windows 8, and now it seems that somebody’s trying to make MacOS look the same … ? – Manngo Sep 30 '18 at 9:25
  • It is a bug in macos. Just disable Reduce Transparency and enable it again and tinting will be gone. I do it every time I turn on my laptop. it is annoying. – Iuri G. Oct 16 '18 at 20:49
  • @luri-g Are you sure? I doesn’t help with Finder windows. – Manngo Oct 17 '18 at 8:04
2

Set your Desktop background color to pure white:

System Preferences > Desktop & Screen Saver > Desktop > Colors > Custom Color… > Color Palettes > White (double click)

Even in the “Reduce Transparency” mode, Mojave calculates background colors off the desktop wallpaper, so having white there ensures light backgrounds. The contrast with text is much better.

Also, the setting “Increase contrast” in Accessibility > Display gives the best contrast, but it adds black edges to UI elements.

1

At the moment, the best option seems to be not reducing transparency and living with the blurred background. At least then, you get a tint of what's behind the app, instead of the sometimes-completely-unrelated desktop wallpaper.

Another slightly ugly option would be to use a solid gray as your desktop background.

  • 1
    Solid gray background is the workaround I chose, as well. But workarounds are just that: workarounds. I’ll probably file a bug with Apple about this behavior, as it seems just completely wrong (maybe no in QA turned on Reduce Transparency?). – Andrew Marshall Sep 28 '18 at 0:10
0

It's really horrible. It's not really a solution, but I got round it by using 'Yosemite 3' as my desktop picture. The colour you get from that is pretty close to what it used to be.enter image description here

Really hope they add an option for this soon like they did for the translucent menu bar.

-1

Try using the 'Reduce Transparency' option under Accessibility:

System Preferences - Accessibility - Display - Reduce Transparency

  • 1
    As stated in my question, this problem occurs when using Reduce Transparency. – Andrew Marshall Sep 28 '18 at 0:08
  • @AndrewMarshall what you are encountering is a bug that appears after restart or sleep of your mac. If you go back to Accessibility and disable and then again enable Reduce Transparency it will be fixed. I do it every single time and I know how annoying it is – Iuri G. Oct 16 '18 at 20:48
  • @IuriG. See my reply to your comment on the question itself. – Andrew Marshall Oct 17 '18 at 13:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .