8

Installed Mojave yesterday - everything is fine except the App Store doesn't show Discover or any of the other tabs - it only shows Updates - see screen grab. The search function works so it's connected fine. I've tried deleting all caches, etc

enter image description here

  • 1
    I have the same problem, app store shows nothing. – DWY Sep 26 '18 at 0:15
  • 2
    ...if someone can figure out how to replicate this "problem" on any machine, I would do so on mine! Nice and minimalistic, and I can still search if necessary! – Wowfunhappy Sep 26 '18 at 0:33
  • Same problem here. Thanks for any updates on a fix! – Steve Winslow Sep 26 '18 at 5:42
  • @Buscar웃 That's just a link to my account info - I'm definitely on the right page – Robert Softley Gale Sep 26 '18 at 8:15
7

I have found the solution (and origin) to this problem. Thanks @charles for giving me the insight.

The problem occurs because the new Mac App Store app CFBundleVersion is marked as 1 so if you have any copy of the old Mac App Store (which had CFBundleVersion over 459) in the system, macOS will think is the most recent version and will try to use it on the background.

This is why if you go the the Apple Logo > App Store… it tries to open the old version.

Deleting the old app bundle from the system resolves the problem.

  • 1
    how do you delete old bundle CFBundleVersion – Ruskes Oct 5 '18 at 3:17
  • @Buscar웃 You just need to delete the old version of the App Store that you have somewhere in your file system. Spotlight wasn't pulling it up for me, but I realized I had a backup of an old Macbook on my file system & found the offending App Store app in there. – Nobosi Oct 8 '18 at 7:32
1

I am seeing the same issue. Not really an answer but more diagnostic info:

  • MBPro early 2015, 13-inch Retina
  • Tried resetting PRAM
  • Tried starting up in safe mode
  • Tried deselecting all the boxes in the advanced tab of the software update preferences
  • Tried launching it from terminal (don't know why I thought that would work)
  • Ran
  • disk first aid
  • Created a new user account and I could see all the tabs in that account.

Because the test user was vanilla, I am guessing there is something booting up in the primary account that is causing a conflict. Primary account is an admin and test account is a standard user without admin privileges.

  • Just tried another account on my mac and the App Store is working fine, so yeh something must be blocking it – Robert Softley Gale Sep 26 '18 at 8:17
1

I have exactly the same problem. I can only see updates in Mojave App Store, but if I open the App Store, then follow this with opening the app store from the Apple Logo menu top left, I can also open the old High Sierra App Store which has all the apps ..... It also seems to revert my location back to where I bought the iMac a couple of years ago ...

  • Update: I definitely have 2 versions of App Store v2.4 and 3.0. How do I delete one of these as the permissions will not let me remove the old v2.4 per the description from @pvieito. Thanks – charles Sep 29 '18 at 9:20
  • Mines asked for password before moving 2.4 to trash, but it let me do it. – Robert Softley Gale Sep 29 '18 at 9:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .