5

When I was installing Mojave, the installer went up to the analytics page on which I disabled everything. Upon proceeding, the installer froze on the analytics page. I waited five minutes and force rebooted, coming back to find that Mojave seemingly installed successfully, given that it let me log in to my account and desktop.

Did I miss any options when I did this?

  • This happened to me too, on a Retina MacBook Pro (Late 2013). It got stuck on the Analytics step. I'm guessing this is a Mojave bug. I force-rebooted and everything looks good; checked the filesystem with Disk Utility and no problems found. The only thing past Analytics is "Setting Up Your Mac...", and I don't know what that does, but I seem to be okay without it. – Brian Kendig Sep 26 '18 at 16:43
  • It should setup stuff like iCloud Drive or iMessages. I've also had this problem and forced the shutdown. After the restart I could login and had everything setup like I had on HIgh Sierra. – Markus Rudel Sep 28 '18 at 19:01
  • Same here, but I believe it is not so common to stuck here and for what I have been reading, this is the most close to “successfully instalattion” I know, however uncomfortable it might be. anyway, my reboot was very fast (2m)... I checked and for now everything seems ok. After stuck I waited 10m to force restart. Anyone knows if I should reinstall or because everything seems ok I should keep stil? Since reboot I haven’t felt nothing different, slow or even strange! What I really do not understand is how MacBook Pro can freeze and than reboot with everything (apparently) ok. Thank you very muc – Ruben Neves Oct 3 '18 at 0:21
1

same issue

For me the same issue occured it stoped at setting analytics step for 30 min . Finally had to force reboot. Reboot took longer time( 50 min ) so I had to force reboot again. Tried command +option P+R while rebooting it worked everything seems to be ok

0

You can check if those settings you've deselected are still present when you go to your System Settings, Security & Privacy, Analytics page. In my case, the installer did not complete but I've delected all those options and they are still disabled:

enter image description here

As for the part about what you are missing from the installation process when it is displaying "Setting up your Mac..." I would guess its stuff like iCloud and similar stuff which you should be able to verify also from the System Settings.

0

Next screen is ‘Choose your Look’ where you can choose between light or dark mode. After that it’s just a screen saying it’s finishing setting up the Mac.

-2

I encountered the same issue. Force restarting the Mac resolved it in my case.

You must log in to answer this question.

protected by Community Nov 18 '18 at 12:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .