I have an MacBook with OSX and backed up everything in a Time Capsule with Time Machine. Now I bought a MacBook Pro with Lion and then migrated everything from the old computer to the new using Migration Assistant and the Time Capsule, everything went right in other words the Migration Assistant said: the data was copied successfully.

The problem is that I can see all the data on my new computer but they seemed to be blocked because when I would like to open them there is a message which says they are blocked because I have no rights.

I have restarted my computer already and renamed my computer the same name as my old computer, no good.

  • If the answer by @iolsmit below doesn't solve the problem, you please post the exact error message (screen shot is ok as well)?
    – nohillside
    Dec 15, 2011 at 17:18

4 Answers 4


Sounds like the permissions are "wrong" or rather the owner is. Click on the folder, press Command+i, in the "Sharing & Permissions:" section (on the bottom) and check if it shows your new user-account on the MBP as owner (first icon) and if the privileges are "Read & Write".
Probably it will show a different user as owner. You could then try to fix the permissions by running Disk Utility, selecting you OS X partition on the left and click "Repair Disk Permissions" - but maybe this won't fix it, then you have to do it using the Terminal.
Maybe someone else can elaborate on that.

Edit 2011-12-18: Ok, I'll try myself:

Something I didn't know yet but found now looking for an easy fix:

From Troubleshooting permissions issues in Mac OS X

Note: In Mac OS X 10.5 and later, while started up ("booted") from the Mac OS X 10.5 installation disc, a user's home directory permissions can be reset using the Reset Password utility.

  • But in Lion they removed the option form the menu, so if you boot (holding "alt ⌥") into Recovery HD
    • Wait for “Mac OS X Utilities” menu to appear, indicating that you are booted into recovery mode
    • Click on the “Utilities” menu and select "Terminal"
    • Type the following: resetpassword
    • Confirm the user account and then the password change and reboot Mac OS X 10.7 as usual with your new password

Copied from Reset a Mac OS X 10.7 Lion Password

I didn't try it myself, but hopefully this should reset/repair your home directory permissions.

Maybe even better solution using Finder in normal OS X:

  • In Finder select the folder
  • Press Command+i
  • Expand "Sharing & Permissions" section (Unlock if necessary 1)
  • If you're not in the list of owners, press [+] 2
  • In the upcoming list, select your new user
  • Finally click the gear 3, make your new user the owner, apply to enclosed items
    • and delete the old user by selecting his name from the list and clicking [-]


Easiest way, if you're not afraid of the terminal:
Assuming your new user is named harmen

sudo chown -R harmen /Users/harmen  

This will make you the owner of everything inside /Users/harmen
Read more here

Good luck.

  • hmm didn't work. Did run disk utility still the file is blocked. Its says that "Harmen backup" is the owner with all the rights, who can help me out?
    – harmen
    Dec 17, 2011 at 13:51
  • I expanded my answer by three options, any one should resolve your issues
    – iolsmit
    Dec 18, 2011 at 1:21
  • the second option it worked great, still strange that the migration assistant didn't took over all my settings and all but i happy with all the data music and pictures! Thanks very very much, cheers Harmen
    – harmen
    Dec 18, 2011 at 20:39

I've just had the same problem after using Migration Assistant. In my case, I went through the initial setup process on my new computer first, choosing to defer the data migration part of it til some time later - this is the problem. Going through new computer setup without data migration (choosing to do that later) creates an extra user, then when you later do the data migration it messes everything up with the locked folders etc. Big headache. I've learnt the hard way. Read the following, it's very helpful: http://pondini.org/OSX/MigrationProblems.html

  • 1
    Answers on Ask Different need to be more than just a rephrasing of the question and a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone.
    – nohillside
    Aug 4, 2013 at 13:29

I have just found a fix and I've realised its the same as posted just above

Basically "Get Info" then at the bottom of the window next to the gear icon click on the + button. In the next window choose your account name. It creates a new permission category. then just choose Read & Write and apply to all enclosed. I have just done this to 3 machines. It's magic! and after 3 hours of frustration.


I opened my "terminal" ( command line) and changed the permissions from there. sudo chown username filename did the trick.

If you're familiar with unix command line this is way easier.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .