0

I just unburied an old 2007 Mac Mini Server which I had put a 1TB drive into. I had kinda forgotten why it broke, but after a while I remembered...the hard way.

That Mac's hard drive is so full and loaded that it pretty much literally has not a single bit - not byte, bit - of free storage. As MacOS tries to extend the disk journal when mounting, it hits a limitation and fails to mount. I realized that during Target Disk Mode when I was hoping to get in there in order to hopefuly just erase some stuff off it so it would boot properly again.

It does actually go into the boot, but it does NOT actually boot - it just hangs up, and stalls.

I am currently considering to try and breach in using GParted - but I am actually not sure if I had encrypted the drive with FileVault... So just in case, here's the question:

  • How can I possibly resurrect that old Mac Mini Server from my own Mac? I can see the drive as /dev/disk3 and especially the mount voluem as /dev/disk3s2. But with each mounting attempt, a new disk node pops up, eventually even growing beyond 10 (disk10, disk11, ...).
  • If I can not do that from another Mac, is there something else I can do? Like, I had considered to utilize GParted, but I bet there are also other solutions. Which ones would you recommend?

I also can not absolutely - although its not very likely - rule out that the disk itself is broken too - either the reader or the motor. Any way that I can figure this out?

Thanks!

  • Obviously you have a second MAC, Connect them in Target Disk mode and free some stuff. – Ruskes Sep 23 '18 at 16:26
  • @Buscar웃 Tried so, but this is when the multiple disk nodes showed up in an increasing way. When OS X tries to mount the disk, it fails. – Ingwie Phoenix Sep 23 '18 at 17:35
  • Did you try accessing it from Terminal ? – Ruskes Sep 23 '18 at 17:45
  • @Buscar웃 Did - mount failed, produced a new disk node instead. Also tried fsck and a couple others. I suspect that each time OS X tries to mount it, it fails to append to the disk journal and therefore fails. – Ingwie Phoenix Sep 23 '18 at 21:19
  • 1
    @Buscar웃 DiskDrill is not free - I have it installed already. I could try to use it, yes, but I would get a very unusable output as it does not recover filenames, just files in the free version. I would have to buy it to get the actual restore that I want... In the worst, I will have to buy it anyway. – Ingwie Phoenix Sep 23 '18 at 23:54
2

Create a bootable USB stick and boot the Mac off that. Make sure to use a MacOS version that is at least as recent as the Mac Mini’s date of manufacture, but not so new that it doesn’t support a 2007 Mac Mini. Apple’s instructions for creating a bootable USB drive are here. Then you can mount the hard drive (as long as you have the password, if it’s encrypted) and delete some files. Remember to empty the trash to actually get rid of them.

  • I tried to access it via Target Disk Mode, but couldn't seem to mount the disk. It would appear in diskutil list, but each mount attempt - if my own or by the OS, would result in failure or more /dev/disk nodes to show up. Do you think it is a difference to actually boot OS X on the same maschine and mount then, towards using Target disk mode? – Ingwie Phoenix Sep 23 '18 at 17:36
  • I don’t know that it would be better, but it’s certainly worth trying. – Mike Scott Sep 23 '18 at 17:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .