0

About three days after upgrading from iOS 11.4 to iOS 12 my messages and phone apps (recents & voicemail) started showing only phone numbers, not contact names. In some cases, they would display "Maybe: [name]".

Trying to figure this out, I noticed that my contacts app was not formating numbers correctly. Instead of (123) 456-7890, it would show 1234567890.

I tried a lot of fixes that were suggested on the internet (edit one contact, restart, stop the apps and re-start, etc.) but none worked.

How can I fix this?

1

I figured this out. Note that this fix works for an iPhone 5s running iOS 12, with contacts synced to Google/Gmail. Your mileage may vary.

The problem seems to be that the phone numbers in the contacts app have lost the proper format. They should be in the form (123) 456-7890 and they have become formatted as 1234567890. It seems that iOS does a really literal comparison and it can't resolve this difference. I tested this theory by editing a contact to put a "+1" international code in front of the number. That forced the number into the correct format and the phone app and messages then displayed that person's name.

The challenge was how to do this without editing every phone number.

I fixed this by changing my region from the US to Canada. That evidently forces a re-formatting of the erroneous numbers. Then I changed it back to the US.

Go to Settings, General, Language&Region, Region, select "Canada", then press "Done" (I bet selecting any region would work). The change takes a bit of time. When it is complete, look at your recent calls, voicemails and messages--they should be displaying names. Look at your contacts--phone numbers should be correctly formatted. If so, the problem should be fixed. In any case, change the region back to "United States."

Good luck, I hope this works for you.

  • This totally worked for me also. Thank you ... I did not want to add +1 to all my contacts! – Steven Daly Oct 24 '18 at 2:45
  • Wow thank you. Would love to know why all my phone numbers got reformatted in the first place. – Chris Dec 5 '18 at 3:00
  • Me, too. Glad it helped. – Volga89 Dec 5 '18 at 15:43

You must log in to answer this question.

protected by Community Nov 15 '18 at 17:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .